WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can any CSS experts figure this out? (7 posts)

  1. The Night Fox
    Member
    Posted 2 years ago #

    Ok so I'm trying to install an aweber email web form to my sidebar here. It will sit nicely in my sidebar, but as soon as I enter the code <div class="title"><h3>Get the latest coupons</h3></div> the web form is pushed to the right of the sidebar due to what I'm guessing might be some sort of padding issue? Can anyone guide me through the process of creating a custom <div class="title"> to help me solve this problem?

    <div class="box box-widget">
    		<div class="title"><h3>Get the latest coupons</h3></div>
    		<div class="interior">
  2. peredur
    Member
    Posted 2 years ago #

    I think we'll need a link to your site so we can see what's going on (in Firebug).

    Cheers

    PAE

  3. The Night Fox
    Member
    Posted 2 years ago #

    Hi, thanks for your reply. I linked to it in the first post but maybe I didn't really make it that clear. You can also visit it by clicking here.

  4. peredur
    Member
    Posted 2 years ago #

    Your title (which is an h2, by the way) is floated, so the form doesn't clear it. Adding this rule should do it:

    #af-form-1425325552 {
      clear: left;
    }

    HTH

    PAE

  5. The Night Fox
    Member
    Posted 2 years ago #

    Thanks for the quick reply! That worked perfectly, you clearly know what you're doing!

    I have just one other question though. As you can see the form now is where it should be, but is there a way to create a rule so that there is even space around the form? As you can see, there is more space at the top of the form than the bottom.

    Thanks,

    TNF

  6. peredur
    Member
    Posted 2 years ago #

    Or just lucky...

    Something like this?

    .af-form-wrapper {
      padding-bottom: 20px;
    }

    Firebug is the best thing that ever happened to me (apart from marrying my wife, of course).

    Cheers

    PAE

  7. The Night Fox
    Member
    Posted 2 years ago #

    Ok everything is working perfectly now, thanks once again for your expertise! Haha with a recommendation like that I think I'm going to have to try firebug for myself!

    Thanks again,

    TNF

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.