WordPress.org

Ready to get started?Download WordPress

Forums

Call to undefined functions (13 posts)

  1. ronchicago
    Member
    Posted 5 years ago #

    1) i just went to my site and i get the following error =
    ****
    Your favorite left sidebar content goes here
    /*
    Fatal error: Call to undefined function: stp_posttags() in /home/domain.com/wp-content/themes/3c-black-letterhead/leftsidebar.php on line 12
    ****

    2) then i went inside admin to look = design > widgets = found this is broke as it shows zero widgets in either of my two sidebars which is incorrect.

    3) i have done nothing to the site in several days. my traffic has been really heavy the past two days thanks to stumble and i might have been hacked or something simply broke. i did a database backup 8/21. my thoughts are just to restore by db back to 8/21 and maybe it will be ok.

    any advice here. thanks.

  2. ronchicago
    Member
    Posted 5 years ago #

    upon thinking further, additional info. i also backed up my wp files 8/21. maybe a wp file is corrupt? any best practice to find the culprit, i.e., first look at wp files vs db? i am currently on v2.5.1 and thought the v2.6.1 upgrade was not a big enough upgrade to make a change on a smooth running site with a lot of widgets. if i am looking for a wp issue, best to stay on 2.5.1 and fix it before upgrading to 2.6?

    if it is better to replace a wp-file(s) one at a time what files relate to the sidebar, widgets, plugins. sidebar files seem obvious, anything else? widgets/plugin files in wp-admin, wp-includes, respectively?

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Did you disable any plugins? Simple Tags, perhaps?

  4. ronchicago
    Member
    Posted 5 years ago #

    otto, that was the first thing i did = no effect. i did not disable any others.

  5. ronchicago
    Member
    Posted 5 years ago #

    one thing i just remembered. mid-week i modified feedburner code. yesterday, early evening, i generated a feedburner "headline animator" widget and dropped the code into an existing text sidebar widget. however, nothing changed and i went to dinner and did not take it off. i don't know if that widget kicked in overnight and triggered something.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    No, that was sort of my point. Disabling Simple Tags is what gave you the stp_posttags error.

    Turn Simple Tags back on, and that error will go away.

  7. ronchicago
    Member
    Posted 5 years ago #

    otto, agreed, i failed to mention i did reactivate. i deactivated and reactivated again since per your suggestion. also tested on two other computers. no change. more new info = the only other activity the past few days was blacklisting ip's.

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    You're really all over the place here, man. Calm down and pay attention.

    I'm talking about one and only one specific problem here. That would be this one:
    "Call to undefined function: stp_posttags()".

    The reason you are getting THAT specific error is because you're missing a plugin or don't have it activated or whatever. Your theme is trying to display tags, but it can't because the plugin you had that did those tags is not there.

    That's the problem.

  9. ronchicago
    Member
    Posted 5 years ago #

    i did focus on the stp_posttags() = i deactivated/reactivated the simple tag plugin...twice now. THAT plugin = v1.5.7 installed 5/08 when i upgraded to wp v2.5.1 has been running problem-free. simple tags is currently active. my last post where i added tags was 8/20 prior to my 8/21 bkup. the problem surfaced late 8/24 or early 8/25.

    i am past simple tags on/off. right? the suggestion was now trying to go back to where i was B4 the problem. either pursuing a db or wp restore, or both? install a fresh simple tags? something else?

  10. ronchicago
    Member
    Posted 5 years ago #

    otto, reread my note: what you hear in my voice is me leaving for a week very early tomorrow with little chance of computer access. would like to solve this prior to my departure. this site seems to unfailingly break either the day before a vacation or while on it... ;-)

  11. ronchicago
    Member
    Posted 5 years ago #

    i am not bumping this thread but i have to decide to do something in the next four hours or do nothing until i return. so i am moving forward slowly and sharing my progress. let me know if this is a problem.

    it appears there is no more support for this plugin per the author's website. comments closed 3/08.

    reading into what otto said i did a fresh install of the plugin thinking maybe the plugin crashed. i activated/deactivated/activated and the error has not gone away. it seems this process does not clear any data. there is an uninstall option that would clear tables but that sounds like it would wipe out all my tags. i don't want to do that.

    i also wondered if order of deactivation made any difference so i deactivated all plugs except for (simple press forum, top commentators widget, secure and accessable php contact form) and reactivated in this order (simple tags, executable php widget, minipost2, sabre) with a quite a few still deactivated. the problem still exists.

    surprising there are so few links ( google/wp forum ) regarding this popular plugin with this issue.

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The only other thing you can do is to edit your theme and remove the call to stp_posttags.

  13. ronchicago
    Member
    Posted 5 years ago #

    i just restored database. did not lose much at all as i have gotten into the habit of backing up frequently. everything at first glance seems to be working...

    thanks for jumping in and helping.

Topic Closed

This topic has been closed to new replies.

About this Topic