WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Call to non-existent resource slowing page load (10 posts)

  1. Barnez
    Member
    Posted 1 year ago #

    Hi,

    My site load is being slowed by a call to a non-existent resource.

    The site is http://www.air-8.com and the bad request is listed as http://www.air-8.com/text/javascript.

    Could this be theme related?

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    1. Do you have any plugins installed? If so deactivate them and see if it helps.
    2. Revert to Twenty Twelve theme and see if it helps.
    3. Check your content/uploads folder and look for any wrongly placed files.

  3. Barnez
    Member
    Posted 1 year ago #

    Thanks for your advice Krishna.

    I have been digging a little more, and the breakdown of the call in tools.pingdom.com shows the origins as a WordPress codec file in the root: xmlrpc.php

    WordPress lists this file as being enabled as standard since 3.5: With WordPress XML-RPC support, you can post to your WordPress blog using many popular Weblog Clients. The XML-RPC system can be extended by WordPress Plugins to modify its behavior.

    I've tried to rename the file but the bad request still remains. I will work through your 1-3 advice above, as perhaps a plugin is in conflict with WordPress.

  4. Barnez
    Member
    Posted 1 year ago #

    I tried deactivating the plugins and switching theme to Twenty Twelve did not make a difference, though I would not feel to confident about examining the content/uploads folders to see if anything there is incorrectly placed. Also downloaded a plugin to disable XML-RPC, but the bad call is still active, and slowing the site load by 2-3 seconds.

  5. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Did you try replacing (after deleting) WordPress excepting wp-content folder?

  6. Barnez
    Member
    Posted 1 year ago #

    I will keep your suggestion in mind, but I would prefer to locate the problem if possible. I will keep trying to narrow down the cause.

    Many thanks for your advice.

  7. Barnez
    Member
    Posted 1 year ago #

    Traced the issue to my custom theme as after I cleared the cache on twenty twelve the issue resolved.

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Happy to note that you could solve the problem. :)

  9. Barnez
    Member
    Posted 1 year ago #

    Yes, and thanks again for your advice Krishna. Slowly but surely my WordPress diagnostic skills are improving, especially with support from the WordPress community!

  10. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Everyone starts like that only. The most important thing is that you keep continuing and exploring new possibilities. And perhaps, you can contribute even to further development. Cheers! :)

Topic Closed

This topic has been closed to new replies.

About this Topic