WordPress.org

Ready to get started?Download WordPress

Forums

Events Made Easy
[resolved] Calender Widget shows index of /WordPress (9 posts)

  1. Ulfsby Webdesign
    Member
    Posted 1 year ago #

    When clicking next month in the event calendar widget, the widget shows a list of all files in the WordPress root directory. See vingerlaget.org

  2. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    This has nothing to do with EME: when clicking on the next month, your webserver returns a 301 (redirect) and then shows the index you see.
    So there's something wrong with your wordpress settings (check your "homepage" settings).

  3. Ulfsby Webdesign
    Member
    Posted 1 year ago #

    The homepage settings are like my other 25 sites where there are no such problems. I also deactivated all other plugins with no effect.

  4. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    It seems to have something to do with qtranslate:

    http://vingerlaget.org/en/wordpress/?eme_ajaxCalendar=true&calmonth=6&calyear=2013&full=0&long_events=&category=&author=&contact_person=&location_id=&lang=en#

    works, while

    http://vingerlaget.org/wordpress/?eme_ajaxCalendar=true&calmonth=6&calyear=2013&full=0&long_events=&category=&author=&contact_person=&location_id=&lang=en#

    gets redirected. (notice "lang=en" at the end)
    I have to test this at home, but for now: is there an option in qtranslate to allow lang=en as well?

  5. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    Also: it seems you need
    http://vingerlaget.org/?eme_ajaxCalendar=true&calmonth=6&calyear=2013&full=0&long_events=&category=&author=&contact_person=&location_id=&lang=en

    which works ok as well.
    So somehow http://vingerlaget.org/wordpress/ is being taken as base for the prev/next month ...
    Is that from an old install or so?

    Edit: the base http://vingerlaget.org/wordpress is being taken as a result from the wordpress function site_url(), so somehow your site_url is wrong ...

  6. Ulfsby Webdesign
    Member
    Posted 1 year ago #

    If I deactivate qTranslate, the issue is still there. If I deactivate all plugins, the issue is still there.
    The WordPress URL is set to http://vingerlaget.org/wordpress
    The site URL is set to http://vingerlaget.org

  7. Ulfsby Webdesign
    Member
    Posted 1 year ago #

    If I deactivate qTranslate, the issue is still there. If I deactivate all plugins, the issue is still there.
    The WordPress URL is set to http://vingerlaget.org/wordpress where WordPress is installed.
    The site URL is set to http://vingerlaget.org
    This is how I usually set up the sites. See http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  8. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    so why don't I see index.php in the wordpress subdir? see step 7 of the link you provided. The way you have it now, site_url() will give issues for every plugin using it.

  9. Ulfsby Webdesign
    Member
    Posted 1 year ago #

    Ah, that's it. I must hav moved, not copied, index.php. This fixed the problem. Thank you very much for your good support!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.