WordPress.org

Ready to get started?Download WordPress

Forums

Lazyest Gallery
[resolved] Caching thumbs (12 posts)

  1. thoughton
    Member
    Posted 3 years ago #

    Installed this today, seems to be working ok in it's default state. However I noticed that it is quite slow displaying each thumb, presumably because it is creating them on the fly.

    However when I turn on 'Enable thumbnail caching', instead of displaying the thumbnails it shows a purple 'barber pole' animation in place of each thumbnail. This animation goes on forever. If I FTP into my server I can see that that the plugin is not creating a 'thumbs' folder. I also tried creating my own 'thumbs' folder and giving it 755 permissions, but the barber poles still appear. Any ideas much appreciated!

    On an unrelated note, do you anticipate any problems using this plugin to display the same gallery on several different pages?

  2. thoughton
    Member
    Posted 3 years ago #

    Oh yes, is there a list of which Lightbox/Thickbox plugins are supported? I am using Lightview on my site (not via a plugin) and LG doesn't seem to find it.

  3. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 3 years ago #

  4. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 3 years ago #

    LG checks for known and tesetd WordPress plugins only.
    If your own plugin is working, you can enable the setting anyway.

  5. thoughton
    Member
    Posted 3 years ago #

    Thanks for the quick response :), but which part of the FAQ are you directing me to?

    GD works on my server, as I am using it in other places.

    Permissions seem to be okay. LG can create the slides folder, but it doesnt create the thumbs folder.

  6. thoughton
    Member
    Posted 3 years ago #

    After re-reading your post you seem to be saying I might be running out of memory? I don't understand why caching the images to disk take more memory than just displaying them, but perhaps that is the problem. I will assign more and see if it works.

  7. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 3 years ago #

    Please unselect the setting Create cached thumbnails after page has loaded in the browser

  8. thoughton
    Member
    Posted 3 years ago #

    Cool, thanks :) I unchecked that box and now it seems to be working. I can see the thumbnails being created in the thumbs folder.

    However the slides folder has now vanished. It doesn't really matter to me as I won't be using the slideshow, but thought you might like to know.

    Thanks for all the help!

  9. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 3 years ago #

    After changing the thumbnail setting, LG may clear the cache.

  10. thoughton
    Member
    Posted 3 years ago #

    I see, thanks for the explanation!

    Out of interest, is the Create cached thumbnails after page has loaded in the browser setting intended to postpone the slow thumbnail creation process until after the page load?

  11. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 3 years ago #

    It should load the thumbs one by one through javascript.
    If you upload many images by ftp, this could be handy.
    But sometimes it doesn't work. I'm investigating why not.

  12. thoughton
    Member
    Posted 3 years ago #

    I see, good luck with tracking it down.

    By the way, in version 1.0.35 the 'Visit plugin site' link on the Plugins page in WP admin section is broken. It links to brimosoft.nl/lazyest/galery/ (missing an 'L' in gallery). I was looking for a 'donate' link, which I will use as soon as the client settles his invoice!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic