WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cached Posts: strange characters appear like †  (5 posts)

  1. jkjliu
    Member
    Posted 6 years ago #

    I recently installed the WP-Supercache plugin. It seems to work great -- my posts load in 2 seconds instead of 6-25 seconds!

    However, I'm seeing odd, strange characters in my posts like ”  and a few other odd characters.

    I saw the same thing when I previously tried WP-Cache, a different cache plugin.

    The following is what I think I've figured out so far:

    I only see the odd/strange characters with IE and Safari, not with Firefox.

    It may have something to do with my host, dreamhost. I've contacted their Customer Support and am waiting to hear back from them.

    An apostrophe seems to get replaced with: ’

    After an exclamation point, there frequently seems to be: Â

    Â seems to be scattered around many cached posts.

    When I researched this problem in WP forums and in the plugin author's blog, I found discussion threads related to "compression", "php.ini", ... (which don't mean much to me because I am a beginner programmer)

    I do have Super Cache Compression disabled on the WP-Supercache admin page.

    It seems like many other people have had this problem with the cache plugins, but I haven't found a clear resolution posted anywhere. Thus, if we figure out a resolution, I think it would be helpful for many people.

  2. jkjliu
    Member
    Posted 6 years ago #

    Turned out to be simply UTF-8 encoding.

  3. blazey
    Member
    Posted 6 years ago #

    And that means?

  4. theapparatus
    Member
    Posted 6 years ago #

    They didn't have utf-8 set as their charset in their wp-config.php file. If it's not set, it defaults to whatever is standard on their box (for me, it's latin1 for some strange reason) and that will occasionally cause the issues as noted above.

  5. blazey
    Member
    Posted 6 years ago #

    I think I see. So wp-cache has charset utf-8. If that doesn't correspond with your charset in wp-config there will appear strange signs.

Topic Closed

This topic has been closed to new replies.

About this Topic