WordPress.org

Ready to get started?Download WordPress

Forums

WP Fastest Cache
[resolved] Cached pages not being served - Cloudflare issue? (27 posts)

  1. UltraMarathonEER
    Member
    Posted 5 months ago #

    I have Cloudflare CDN enabled on my site, and up until a few weeks ago, my cached content was being displayed properly through the CDN (meaning, the WP comments were at the bottom of each file). For the past couple of weeks, I've noticed that the cached pages are not being served through my browser (multiple browsers, logged in and not logged in). I finally have had some time to troubleshoot a little bit this afternoon, and have found that when I have Cloudflare enabled, it never seems to pull the WP Fastest Cache page. It pulls the non cached page. If I disable Cloudflare, I then see the WP Fastest Cache cached page. I purged the cache on Cloudflare, then enabled Cloudlfare again, and sure enough, it shows the non cached page again. If I disable it, then the cached page with your comments shows up. I know this was working a few weeks ago, so I am not sure which update caused the problem. I hope I've given you enough detail.

    https://wordpress.org/plugins/wp-fastest-cache/

  2. UltraMarathonEER
    Member
    Posted 5 months ago #

    By the way, I followed the instructions you gave Webz, and disabled, deleted, redownloaded and reinstalled the latest version, and it still continues to do the same as described above.

  3. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    can you tell me your url please?

  4. UltraMarathonEER
    Member
    Posted 5 months ago #

    freedomrunusa dot com

  5. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    what does "Enable/Disable cloudflare" mean? Are you doing it with a another plugin?

  6. UltraMarathonEER
    Member
    Posted 5 months ago #

    No...in cloudflare itself. If I temporarily pause the service on the Cloudflare CDN site, I then run the test, I see the cached page from WP Fastest Cache. If in Cloudflare, I then re-enable the service, it goes back to the uncached version. I even purged the cache in Cloudflare so it would have to pull the latest content (your cached pages). Another test I did was delete all cached files from my server through your plugin (verified by checking the cache directory via ftp), enabling cloudflare service again on their site, purging their cache, then pulling the page from another computer (that is not logged in as admin). The cached pages are being created, as I see them in the "all" directory. A Shift-Refresh should then start pulling the WP Fastest Cache plugin, but cloudflare doesn't serve them up.

    Sorry if it is not very clear. I love this plugin, as it is the easiest one to work with, simple and very straightforward. The only other thing I could ask is if when you push a change, can you create a new changelog with only the features you changed that time, instead of continuing to add to the latest changelog? Just helps me see what changes are being made instead of trying to remember what was done before and now what you have added.

  7. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    UltraMarathonEER, I am tired of reading your comments :D

  8. UltraMarathonEER
    Member
    Posted 5 months ago #

    not sure how to respond to that. Just trying to give you input on an issue, with as much detail as possible. Maybe a new release in the future will fix it.

  9. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    thank you so much

  10. mbrsolution
    Member
    Posted 5 months ago #

    Hi @UltraMarathonEER, I think what @Emre Vona was trying to say with his comment above

    UltraMarathonEER, I am tired of reading your comments :D

    is that he is very happy to read such a long comment and he used the happy emoticon to let you know. Please remember that English is not his first language.

    He is doing exceptionally great supporting his superb plugin.

    My humble opinion.

    Kind regards

  11. UltraMarathonEER
    Member
    Posted 5 months ago #

    Oh I agree, the support is some of the best when it comes to plugins. I just read it quickly and was hoping I wasn't pushing him away :-)

    I have always appreciated detail, especially when someone goes through the steps of saving me time looking for an answer. Too much detail is too much detail? :-)

    Thank you for the reminder that it's not his first language...I think he is doing an amazing job given that fact. Appreciate all your hard work @Emra

  12. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    Thank you both :) ... UltraMarathonEER, I have added this bug into my toDo list. I will contact you.

  13. Marcelo Pedra
    Member
    Posted 5 months ago #

    @UltraMarathonEER: are you using the official CloudFlare plugin to manage that account? Give it a try. Maybe it helps both of you.

  14. UltraMarathonEER
    Member
    Posted 5 months ago #

    Thanks to both Emre and @Marcelo. I will try the Cloudflare plugin out...I just know it worked before, and not sure when the issue came up. I'm happy to help troubleshoot as much as possible as I love this plugin.

  15. Marcelo Pedra
    Member
    Posted 5 months ago #

    ok, I'm interested in helping because I'm looking forward to migrate from W3 and Super Cache to this cache implementation. Whatever makes my sites speedy will go :)

  16. brightestspark
    Member
    Posted 5 months ago #

    I also use Cloudflare and have the same issue. The only cached page being served is the home page (it was the only one that had the WP Fastest cache comment at bottom).

    I installed the Cloudflare plugin and still have the same issue.

    The cached pages are only being served when I put Cloudflare in development mode.

  17. brightestspark
    Member
    Posted 5 months ago #

    When Cloudflare is in development mode - I notice when I first load a cached page (ie. after I have checked the cache folder to see if the html file for that page is there), it doesn't have the WP fastest cache comment in source code (therefore is not loading the cached file), but when I hit refresh - the cached page loads. Must be something to do with browser caching?

    When development mode is turned off, even when I refresh the page, it does not load the cached page.

  18. Marcelo Pedra
    Member
    Posted 5 months ago #

    @brightestspark: wow, maybe it's any configuration bug in the plugin, or any other plugin interfering with this one...
    Are you using last version of everything? no updates available in your WP, right?
    Have you tried purging the entire CloudFlare cache? (from their webpage). Also, be sure to set their optimization settings as just CDN, don't overload the configuration.
    If the above don't work, wait for a low traffic hour and test deactivating all the plugins AND purging Cloudflare cache, and activate only this plugin and retest. Does it works now? If so, then there's a plugin interfering with this one.

    The problem is that the combination of configs and plugins is so almost infinite, that you can always surprise a developer with this. And if you are using an external cache/CDN, it multiplies the effect :)

    Try the above and let me know. As I said, I'm interesting in migrate to this plugin, but your experience is discouraging me.

  19. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    Hi UltraMarathonEER, I have just tested and my site works with Cloudflare properly.

    Can you check it please? -> http://goo.gl/KQPlMv

  20. conservativeread
    Member
    Posted 5 months ago #

    oh I had this with wp super cache and the fix was to disable cloudflares minification. uncheck minifiy html and js and css in performance tab on clodflares site then clear purge all caches should work. clear your browser too.

  21. UltraMarathonEER
    Member
    Posted 5 months ago #

    Yes, yours is working Emre. Conservativeread, thanks for the suggestion, I will try that out tonight!

  22. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    but UltraMarathonEER, yours works too. I looked at the source code and I realized the minified css files. Why do you think that it does not work?

  23. brightestspark
    Member
    Posted 5 months ago #

    Yes @conservativetread - disabiling cloudflare minify worked. Thank you.

  24. UltraMarathonEER
    Member
    Posted 5 months ago #

    I disabled cloudflare minify for html and now my html pages are cached properly with wp fastest cache as well.

    I left minify on js and css turned on however, and I will test those out later today to see if any change is noticed.

    thank you @conservativeread

  25. conservativeread
    Member
    Posted 5 months ago #

    im glad it helped both of you. I don't use cloudflare any more unless I need the security. but the above are the best settings , have a great day.

  26. conservativeread
    Member
    Posted 5 months ago #

    happy it worked. great day.

  27. Emre Vona
    Member
    Plugin Author

    Posted 5 months ago #

    nice :)

Reply

You must log in to post.

About this Plugin

About this Topic