WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Cached gzip page not being generated (3 posts)

  1. trevordixon
    Member
    Posted 1 year ago #

    Here's my debug output:

    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk: enhanced
    Cache key:          _index.html_gzip
    Caching:            enabled
    Status:             not cached
    Creation Time:      0.191s
    Header info:
    X-Pingback:         http://www.trevorandchristie.com/xmlrpc.php
    Content-Type:       text/html; charset=UTF-8
    Last-Modified:      Wed, 02 Jan 2013 06:46:02 GMT
    Vary:               Accept-Encoding, Cookie
    X-Powered-By:       W3 Total Cache/0.9.2.5
    Content-Encoding:   gzip
    -->

    In my pgcache directory, there's a _index.html, but no _index.html_gzip. If I create a _index.html_gzip by doing something like echo "HI" | gzip > _index.html_gzip, then I get a big HI on the page.

    It seems that it's generating the non-compressed version of the page, but not the compressed one. Why isn't it generating the gzipped version?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. trevordixon
    Member
    Posted 1 year ago #

    phpinfo() reports:

    gzip compression: enabled
    
    ZLib Support: enabled
    Stream Wrapper support: compress.zlib://
    Stream Filter support: zlib.inflate, zlib.deflate
    Compiled Version: 1.2.1.1
    Linked Version: 1.2.3.4
    zlib.output_compression: Off
  3. lijin
    Member
    Posted 1 year ago #

    I don't have a direct answer for you but I believe the caching is indeed working if you turn off the debug information, and the last 2 comments here seem to be correct.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic