WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cache in WP 2.0 beta (12 posts)

  1. ronizzel
    Member
    Posted 8 years ago #

    There is caching by default includin in wordpress yet, but I have one problem with it: If safe-mode on the webspace turned on, then you will getting errors over error.

    can somebody tell me how I coult turn off the caching? it would be nice..

  2. ronizzel
    Member
    Posted 8 years ago #

    sorry, i got it now :D

  3. vkaryl
    Member
    Posted 8 years ago #

    Hi ronizzel, could you please post exactly how you deactivated caching in 2.0 beta, so that someone searching for the info will be able to find a solution?

    Thanks.

  4. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    Could you post the errors so we can fix them?

  5. DraXus
    Member
    Posted 8 years ago #

    I have the same problem. A lot of errors like:

    Warning: fopen(): SAFE MODE Restriction in effect. The script whose uid is 621 is not allowed to access wp-content/cache owned by uid 48 in wp-includes/cache.php on line 285

  6. uberwerks
    Member
    Posted 8 years ago #

    Open your wp-settings.php file and look for this:

    // For now, disable persistent caching by default. To enable, comment out
    // the following line.
    //define('DISABLE_CACHE', true);

    change it to this:

    // For now, disable persistent caching by default. To enable, comment out
    // the following line.
    define('DISABLE_CACHE', true);

    That will disable caching.

  7. Ryan Boren
    WordPress Dev
    Posted 8 years ago #

    The DISABLE_CACHE line will likely disappear from wp-settings.php before 2.0 final. Copy it to your wp-config.php so that it is not overwritten when upgrading.

  8. ronizzel
    Member
    Posted 8 years ago #

    Sry, I thought, it was clear in this forums, uberwerks posted the solution already yet, I slept )-:

  9. DraXus
    Member
    Posted 8 years ago #

    It's works. Thanks uberwerks ;)

  10. Matt Mullenweg
    Troublemaker
    Posted 8 years ago #

    This has been fixed in SVN.

  11. uberwerks
    Member
    Posted 8 years ago #

    "This has been fixed in SVN."

    Yes...I forgot to mention that. Sorry Matt.

  12. miscblogger
    Member
    Posted 8 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags