WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Cache-Control: max-age=3, must-revalidate. Where can this be edited? (6 posts)

  1. hydn
    Member
    Posted 2 years ago #

    .htaccess in /cache folder is set to:

    # BEGIN supercache
    <IfModule mod_mime.c>
      <FilesMatch "\.html\.gz$">
        ForceType text/html
        FileETag None
      </FilesMatch>
      AddEncoding gzip .gz
      AddType text/html .gz
    </IfModule>
    <IfModule mod_deflate.c>
      SetEnvIfNoCase Request_URI \.gz$ no-gzip
    </IfModule>
    <IfModule mod_headers.c>
      Header set Vary "Accept-Encoding, Cookie"
      Header set Cache-Control 'no-cache'
    </IfModule>
    <IfModule mod_expires.c>
      ExpiresActive On
      ExpiresByType text/html A0
    </IfModule>
    # END supercache

    But it makes no differnce. cleared cache and restared and still says:

    Cache-Control: max-age=3, must-revalidate

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Check wp-cache-phase1.php, you'll find it there.

  3. hydn
    Member
    Posted 2 years ago #

    Thanks for the fast support. Of the 3 caching solutions I've tried (W3TC, QC and WPSC) you seem by far to be the most in tune with your user base, actively respond to request, patient and the most approachable from reading through the support forums.

    Kudos!

    Now off to fiddle with headers :)

  4. yohay
    Member
    Posted 2 years ago #

    Hi guys,

    I am searching for the same thing. I tried modifying the the wp-cache-phase1.php file by changing the max age to 86400. Line 167 is now
    header( "Cache-Control: max-age=86400, must-revalidate" );

    I've cleared the cached but it is still set to Cache-Control: max-age=3, must-revalidate

    PHP caching is set and the 304 Not Modified option is set as well in the Advanced settings tab of WP Super Cache.
    Am I missing something?

    I believe that making this work will reduce crawl time of search engines, adding even more value to this excellent plugin.

    Thanks!

  5. yohay
    Member
    Posted 2 years ago #

    Update: this is how my .htaccess in /cache folder look like:

    # BEGIN supercache
    <IfModule mod_mime.c>
      <FilesMatch "\.html\.gz$">
        ForceType text/html
        FileETag None
      </FilesMatch>
      AddEncoding gzip .gz
      AddType text/html .gz
    </IfModule>
    <IfModule mod_deflate.c>
      SetEnvIfNoCase Request_URI \.gz$ no-gzip
    </IfModule>
    <IfModule mod_headers.c>
      Header set Vary "Accept-Encoding, Cookie"
      Header set Cache-Control 'max-age=31556926, must-revalidate'
    </IfModule>
    <IfModule mod_expires.c>
      ExpiresActive On
      ExpiresByType text/html A86400
    </IfModule>
    
    # END supercache

    According to WebPageTest, I get the desired 304 response on a second load with Google Chrome. I don't get it with Firefox or Explorer. Any advice will help.

    Thanks again,
    Yohay.

  6. nowsms
    Member
    Posted 2 years ago #

    I don't know why ... but removing Cookie from the Vary header seems to fix the problem.

    (I have a mix of WP and non-WP content, and I noticed that the non-WP content was returning a 304, but the cached WP content was not. IE would not send the If-Modified-Since header in subsequent requests. Comparing response headers, it came down to including Cookie in Vary header.)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic