WordPress.org

Ready to get started?Download WordPress

Forums

Cache Content is empty even though everything is fine (11 posts)

  1. mharrisr
    Member
    Posted 6 years ago #

    Hi,

    In my wordpress blog I have installed the lates version of WP-Super cache previously wp-cache installed but removed all supported files and installed WP-Super cache, now I cant see the cached pages in the "cache contents". I have no idea whats going wrong, any one have an idea?

    Thank you,

    Regards,

    Harris

  2. Roy
    Member
    Posted 6 years ago #

    As I understand it, Super Cache only caches pages when they are visited, so if you click around on your site and then click on the Super Cache link in you dashboard, you'll have as many pages cached as you visited.

  3. mharrisr
    Member
    Posted 6 years ago #

    Yes there are 100's of visitors coming to my blog and also I have clicked some posts to test whether its working or not, but nothing is stored inside the cache thats why I posted this topic.

  4. Roy
    Member
    Posted 6 years ago #

    Odd. Well in that case you may want to draw Donncha's attention to this thread. He wrote the plugin and usually is pretty quick with answering.

  5. Donncha O Caoimh
    Member
    Posted 6 years ago #

    I've been watching. :) I'm subscribed to this tag but rather busy lately.

    Open your wp-config.php and make sure the "define( 'WP_CACHE', true);" line is above the wp-settings.php include command.
    Is your cache directory writeable?
    Open up wp-content/advanced-cache.php and debug it. Add error_log() commands to figure out what the code is doing.

  6. mharrisr
    Member
    Posted 6 years ago #

    Hi,

    I have tried as per your instruction but failed,still I can't see any files stored inside cache and it does'nt through any error message when include error_log(). If you can check with my blog and sort out the problem I will give you the wp-admin access.

    Sorry for the dlayed reply.

    Regards,

    Harris

  7. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Harris - try to debug it a bit more. Try wp-content/advanced-cache.php
    If an error_log at the start of that file isn't executed then you don't have caching enabled at all!

  8. mharrisr
    Member
    Posted 6 years ago #

    Yes, I have done as you said in advanced-cache.php but nothing was returned so it seems caching was not enabled. So what can I do to enable the cache? but I remember when I installed WP Cache it was stored in the cache but the Super cache is not.

  9. mharrisr
    Member
    Posted 6 years ago #

    I have noticed that the supercache folder and wp_cache_mutex.lock is not creating when I try to install the plugin.

  10. mharrisr
    Member
    Posted 6 years ago #

    Latest update was I have uninstalled wp super cache and installed wp cache plugin now this is also not working, it seems some base configurations are messed up with. We have to identify the problem, can you guess what was happened?

  11. mharrisr
    Member
    Posted 6 years ago #

    I have worked around in the config of my wordpress files, now its working(Super cache). Thanks a lot donncha for this plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic