WordPress.org

Ready to get started?Download WordPress

Forums

TheatreCMS Lite
[resolved] Buy Tix Missing Argument Error (7 posts)

  1. Tisha Oehmen
    Member
    Posted 1 year ago #

    After inserting a URL in the Buy Tickets metabox on the Edit Production Screen, and publishing it. The following error is displayed on the public view of the production:

    Warning: Missing argument 4 for tcms_return_buytixbutton(), called in /home/content/***/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1479 and defined in /home/content/***/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1742

    http://wordpress.org/extend/plugins/theatrecms-lite/

  2. Scott Shumaker
    Member
    Plugin Author

    Posted 1 year ago #

    I'm aware of this issue, but I don't know why it's showing the error publicly. It's just a warning and functions properly. Do you have WordPress in debug mode? I'm working on fixing the error warning.

  3. andy.fx-foreignexchange
    Member
    Posted 1 year ago #

    I have the same issue

    Warning: Missing argument 4 for tcms_return_buytixbutton(), called in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1479 and defined in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1742

    http://wordpress.org/extend/plugins/theatrecms-lite/

    My debug mode is false

    Is there an image missing from the styling of the buy tickets button maybe?

  4. andy.fx-foreignexchange
    Member
    Posted 1 year ago #

    With debug set to true its horrific

    http://prntscr.com/168z5d

    [ Moderator Note: Please post code, log data, or markup snippets between backticks or use the code button. ]

    Notice: Undefined index: tcms_presenter in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1468
    
    Notice: Undefined index: year in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: - in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: month in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: - in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: day in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: year in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: - in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: month in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: - in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: day in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1434
    
    Notice: Undefined index: tcms_sponsors in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1477
    
    Warning: Missing argument 4 for tcms_return_buytixbutton(), called in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1479 and defined in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1742
    
    Notice: Undefined variable: label in /home/theatre/public_html/wp-content/plugins/theatrecms-lite/theatre-cms-lite.php on line 1745
  5. ahbruhn
    Member
    Posted 1 year ago #

    Yep, I've got it too...but it didn't show up until I tried to enter an Event and display it on my static home page.

    Just installed today too! Wanna take a peek?

    http://testarea.abswservices.net/

  6. Scott Shumaker
    Member
    Plugin Author

    Posted 1 year ago #

    Just posted version 1.2.4 which should fix this error. Please update and post if you have any problems. Thanks for your patience!

  7. ahbruhn
    Member
    Posted 1 year ago #

    Awesome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic