WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Buttons are missing when writing posts (14 posts)

  1. greatdanemaniac
    Member
    Posted 3 years ago #

    Hi!
    I was just wondering if all the upload buttons except for the media button + the embed FLV button is supposed to be missing when I write a post?

    I'm using the latest SVN version of WP 3.1 on my computer and it's a bit weird that all of a sudden these buttons are missing. Are they supposed to be gone, or what? Has this something to do with my host? (supergreenhosting.com + cPanel) since the embed button has been missing from my WP 3.0 install that I use on my domain since the upgrade to 3.0 in may 2010.

    Please tell me how to fix this. I really need these buttons!

    P.s. I also have another local install on my computer which is using 3.0.4 and there I have the embed button, so I know that something is not right...

  2. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    Is this multisite?

    Multisite requires the upload buttons to be enabled manually. See Network Admin > Settings and "Media upload buttons" under "Upload Settings."

  3. greatdanemaniac
    Member
    Posted 3 years ago #

    Ahh, never thought about that. I'll check it out later today. Thanks!

  4. greatdanemaniac
    Member
    Posted 3 years ago #

    That solved the problem with the upload buttons, but what about the embed button? is there a reason for why that one is missing?

  5. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    The button on the left here? http://cl.ly/2s0z3n410w0C1I3y3y2P

    Well one, it was never displayed in multisite. Hypothetically you could have added it through some code, but we removed it in 3.1. Hard to believe anyone actually used it.

    Reference: http://core.trac.wordpress.org/ticket/14647

  6. greatdanemaniac
    Member
    Posted 3 years ago #

    Ahh ok. well if it's been removed, that explains a lot.

    The reason I want it is because it's very frustrating uploading a video an only recieving a link to the video. Youtube is very easily embedded, but what if I'd like to upload and embed my own videos? I know that with some code editing this is manually fixable, but I would prefer to do this automatically. Also I haven't found a plugin that does what I want either, so that sucks as well.

    the embed flv button is not perfect either, since it's quite a hassle to provide a link etc. (at least, that's what I think). It's just a far to complicated procedure to use that button, but it's better than nothing if you'd like to embed something uploaded.

    I know that there's been some talk of making the 3.2 version all about media and I really hope that embedding your own video files will be as easily as uploading and deciding the width and heigt of an image.

    Sorry if my english is bad btw. I hope you know what I mean though...

  7. The reason I want it is because it's very frustrating uploading a video an only recieving a link to the video. Youtube is very easily embedded, but what if I'd like to upload and embed my own videos?

    A lot of other external video sites work via the simple link - http://codex.wordpress.org/Embeds

    If you want to upload and embed your OWN media, I would suggest this: http://wordpress.org/extend/plugins/vipers-video-quicktags/ Upload like you would a normal media file, use the quicktags, and it works great on 3.1 :)

    The problem with embedding is that the code to play back videos has to be installed on the server level in a lot of cases. And many of the playback utils aren't GPL friendly. Not to mention playing videos puts more of a strain on servers, and it's not something to be jumped into lightly.

  8. greatdanemaniac
    Member
    Posted 3 years ago #

    Ok, I'll check that plugin out later then. Consider this thread solved. Thank you!

  9. alishiraz89
    Member
    Posted 3 years ago #

    why you removed the button its bad because I use that anyways

  10. Aranor
    Member
    Posted 3 years ago #

    I was using the button to insert videos into manual excerpts. There's no other way I know of to do it. I've tried other plugins, etc, but nothing works. Can't paste html, as it's only a rich text editor. Can't use shortcodes.

    Basically, PLEASE bring this button back. It's the only way to insert videos into excerpts.

  11. alishiraz89
    Member
    Posted 3 years ago #

    Yes please bring that back! :-(

  12. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    Sorry all,

    The plugin was removed due to licensing issues. It should never have been included in WordPress, and was never used by many. It won't be coming back to WordPress core.

    You should look at the oEmbeds feature: http://wordpress.org/Embeds.

    I imagine there are other plugins out there that may be able to leverage this, but the plugin would not be compatible with the WordPress license.

    Regards,
    Nacin

  13. greatdanemaniac
    Member
    Posted 3 years ago #

    I really recommend that you all start using that plugin that I was recommended. It's awesome! It solved all of my issues and now I can embed stuff a lot easier.

  14. Aranor
    Member
    Posted 3 years ago #

    almost works in excerpts. It recognizes the presence of an image/video, but won't show it. Just blank space. Alas, there seems to be no solution.

Topic Closed

This topic has been closed to new replies.

About this Topic