WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Twitter Bootstrap CSS
[resolved] Button Groups and Administration Panel (4 posts)

  1. peregrinlightfoot
    Member
    Posted 1 year ago #

    I'm trying to place a group of Split button dropdowns inside a metabox in the edit/new post screen.

    I've placed the first but when I click it, it only reloads the page.

    here is my code:

    <div class="bootstrap-wpadmin">
    <div class="btn-group">
                        <button class="btn">Action</button>
                        <button class="btn dropdown-toggle" data-toggle="dropdown">
                        <span class="caret"></span>
                        </button>
                        <ul class="dropdown-menu">
                        <li><a tabindex="-1" href="#">Action</a></li>
                            <li><a tabindex="-1" href="#">Another action</a></li>
                            <li><a tabindex="-1" href="#">Something else here</a></li>
                            <li class="divider"></li>
                            <li><a tabindex="-1" href="#">Separated link</a></li>
                        </ul>
                        </div>
    </div>

    Any ideas why I don't have the default behavior?

    http://wordpress.org/extend/plugins/wordpress-bootstrap-css/

  2. Paul G.
    Member
    Plugin Author

    Posted 1 year ago #

    I think the problem here is Javascript... we don't actually include the Bootstrap javascript with the admin bootstrap option.

    I'll add this to the next release. Though, I can't promise you wont have problem with doing that, and that it'll work. We added this option initial so that we would have the CSS bootstrap styling options.

    I'll do it, and you can see what you think and let me know if it works. How's that?
    Cheers,
    Paul.

  3. peregrinlightfoot
    Member
    Posted 1 year ago #

    I've imported javascript into the administration:
    <script type="text/javascript" src="path/to/bootstrap.min.js"></script>

    And It appears to be working.
    If some problem comes up, I'll post it here.

    Thanks

  4. Paul G.
    Member
    Plugin Author

    Posted 1 year ago #

    Good to hear! I'll add it anyway to the next release.

    Thanks for updating me with your results.
    Cheers,
    Paul.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic