WordPress.org

Ready to get started?Download WordPress

Forums

Yelp Widget Pro
[resolved] Business ID not working signature invalid (6 posts)

  1. Marsbliss
    Member
    Posted 3 months ago #

    Been trying to get this plugin to work but not having any success. I've put the API in went to do the business method put business ID but it keeps saying signature invalid.

    My yelp link is http://www.yelp.com/biz/scottsdale-skin-rejuvenation-scottsdale
    I have reviews that have been approved by yelp.

    Used scottsdale-skin-rejuvenation-scottsdale as my business ID.

    I'm following every step it has in the youtube video and it's still not working.

    https://wordpress.org/plugins/yelp-widget-pro/

  2. Devin Walker
    Member
    Plugin Author

    Posted 3 months ago #

    Are there any blank spaces in your API key within the plugin settings?

    If you enter another biz ID in there for another location does the widget work?

  3. Marsbliss
    Member
    Posted 3 months ago #

    There are no blank spaces in the API key and when I try to use another business ID from another company on yelp I get the same signature invalid error.

  4. Devin Walker
    Member
    Plugin Author

    Posted 3 months ago #

    Can you take a look at this thread: http://wordimpress.com/support/topic/no-widget-content-displayed/

    I'm wondering if your serve time has 'drifted' - that's the only reason I could see you receiving this error other than invalid characters and spaces.

    You may also want to try resetting your Yelp API key and inputting the new one in the plugin settings. If that doesn't work, most likely it's your server time is slightly off. It doesn't happen often but I've seen it 2-3 times since releasing this plugin. I hope this helps! Please let me know if you have anymore questions.

  5. Marsbliss
    Member
    Posted 3 months ago #

    Didn't think I was going to get it working but I updated to 3.9 and decided to give it one more try and it worked. Thanks for your help.

  6. Devin Walker
    Member
    Plugin Author

    Posted 3 months ago #

    Great! Glad you got it working. If you like the plugin please consider rating it!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.