WordPress.org

Ready to get started?Download WordPress

Forums

Easy Restaurant Menu Manager
bullets in extended version (19 posts)

  1. jeyon001
    Member
    Posted 4 months ago #

    created a menu while using the free version - when i installed the extended version - the menu changed for the worse - the food items now have bullets - what gives?

    thanks for any help

    --JohnE

    https://wordpress.org/plugins/easy-restaurant-menu-manager/

  2. jeyon001
    Member
    Posted 4 months ago #

    btw - i'm using WP 3.8.1

  3. Richard Royal
    Member
    Plugin Contributor

    Posted 4 months ago #

    You most likely installed it in the wrong place and the stylesheet is 404.

    Watch the install video and see if you can spot your mistake:

    https://www.youtube.com/watch?v=BQ2TF0i9FPQ

  4. jeyon001
    Member
    Posted 4 months ago #

    thanks - the video pointed to one of the problems - the plugin folder had a number at the end of the name - correcting that got rid of most of the formatting errors - except the bullets

    using inspect element - i discovered they are created by the Restaurateur theme i'm using - for a quick fix - i edited out the CSS code

    so - the menus are looking good once again

    i'm particularly happy the menus - categories - and food items are in separate easy to figure out database tables - it made it easy to use sql to enter the tremendous number of food items this restaurant has

    thanks for the plugin

    --JohnE

  5. Richard Royal
    Member
    Plugin Contributor

    Posted 4 months ago #

    Awesome!

  6. duplexd
    Member
    Posted 4 months ago #

    @jeyon001 I have the same theme and same issue with the plugin. Do you mind share which CSS file you edit and how? Thanks in advance.

  7. Richard Royal
    Member
    Plugin Contributor

    Posted 4 months ago #

    Your theme may be overriding the plugin CSS, post a link and we can help you out.

  8. duplexd
    Member
    Posted 4 months ago #

    @Richard Royal http://cotatichinachef.com/menu/lunch
    I just noticed the price display drop down one and half line when the icons is placed.
    Thanks for your help~~

  9. Richard Royal
    Member
    Plugin Contributor

    Posted 4 months ago #

    Your issue is that your theme is adding some content to li elements using the li:before selector, see image.

    http://39b336eb0137a1873e7f-6d49763ac07b3d5e8aa3e5b4de310fe6.r94.cf2.rackcdn.com/Screenshot%20from%202014-03-26%2017:19:34.png

    Add the following CSS to the plugin's dynamic CSS box:

    .wprmm_menu li:before {
    content: '' !important;
    }

  10. duplexd
    Member
    Posted 4 months ago #

    thank you for your prompt response.
    Do you mean to put under this? http://i59.tinypic.com/2vaxbwp.png

    Sorry for posting a "rookie" question here.

  11. Richard Royal
    Member
    Plugin Contributor

    Posted 4 months ago #

    Yes. Try changing the '' to a ""

  12. duplexd
    Member
    Posted 4 months ago #

    Thanks a lot for your help.
    For some reasons, the scripts you provide above does not work for me, but I worked around the theme's CSS to disable the li:before {.
    However, the icons placed in the entrees still making the "price" dropped down. It is clearly shown on the item "Deluxe pizza". Any ideas? Thanks again!
    http://cotatichinachef.com/menu/lunch

  13. Richard Royal
    Member
    Plugin Contributor

    Posted 3 months ago #

    Check out the image of the CSS modifications I made to get it to look right:

    http://39b336eb0137a1873e7f-6d49763ac07b3d5e8aa3e5b4de310fe6.r94.cf2.rackcdn.com/asdf.png

    Something like:

    .wprmm_menu .menu_price img{
    float:left !important;
    padding-right: 5px !important;
    margin-top: 0px !important;
    }

  14. duplexd
    Member
    Posted 3 months ago #

    Perfect!! Many thanks~~

  15. Richard Royal
    Member
    Plugin Contributor

    Posted 3 months ago #

    No problem.

  16. Sandra van der Lingen
    Member
    Posted 3 weeks ago #

    Hi. I'm having a similar problem with bullets on the menu page but I use the free version. I've tried to get rid of them but to no avail. Any suggestions? This is the link: http://pino.h2ocommunications.com.au/?page_id=8

  17. duplexd
    Member
    Posted 3 weeks ago #

    I'm not really good at wordpress. I noticed you have

    .entry-content ul > li {
    list-style-type: disc;
    }

    on your style sheet. Change "disc" to "none" will do the job. But I'm not sure if it is the best way to do it.

  18. Sandra van der Lingen
    Member
    Posted 3 weeks ago #

    Thanks Duplexd! That was it! I've now changed the custom.css in the plugin css folder as follows:

    .entry-content ul > li {
    list-style-type: none;
    }

    Bullets are gone..

  19. duplexd
    Member
    Posted 3 weeks ago #

    No Problem!

Reply

You must log in to post.

About this Plugin

About this Topic