WordPress.org

Ready to get started?Download WordPress

Forums

WebLibrarian
[resolved] Bulk upload more than 15 records (6 posts)

  1. mhustings
    Member
    Posted 1 year ago #

    When I bulk upload a CSV file, only 15 records (the top 15 out of a few hundred) are uploaded. Could this be an error on my part or a limitation of the software? Thanks!

    http://wordpress.org/extend/plugins/weblibrarian/

  2. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    It is probably a error in the CSV file. I have uploaded larger CSV files without problems. If the CSV file has a bad character, the upload process could get confused. Please read the other threads relating to CSV files for details on what to look for.

  3. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

  4. mhustings
    Member
    Posted 1 year ago #

    Thanks so much for your quick reply! I had read through the other threads before starting this one, but with my limited development knowledge, thought this might be a separate issue, sorry for the duplication! The bulk upload finally worked, though I'm not quite sure how. I tried saving as csv, opening as csv then saving as txt, opening a csv file in Notepad to save as txt, then ended up back in Excel saving as a csv, which is what I was doing before, tried another upload and the entire file was uploaded! Several records do not have entries for one column or another, I wonder if this might have been tripping the program up? In any case, thanks for your help and for creating this plugin!! We're really thrilled to have found WebLibrarian for our little special library!

  5. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    My only thoughts are that there is something fishy going on between Excel and MS-Windows and character sets. *I* never had any problems on my Linux system creating CSV files that 'just worked', but I was not using a spreadsheet program, instead I was using a text filtering program (coded in Tcl) to filter from one ASCII format to another ASCII format. Or else I was using a plain text editor. I don't use MS-Windows for my desktop system (and never have).

    I think that somewhere along the way, UTF-8 might be involved and possibly something odd about newlines or item quoting (eg missing quote marks or improper quote marks), but I don't really know. It very likely also depends on the locale setting on the *server* WordPress is running on vs the locale setting on the desktop computer the CSV file was created on. Most often, a pure, 7-bit ASCII file will have no problems, ever. I know that sometimes that is not a viable option, since book titles, descriptions, and author names might possibly require UTF-8 characters. It is important *never* to use anything but 7-bit ASCII characters for the bar code: eg only the digits 0-9, and ASCII letters A-Z and a-z -- note: most bar code scanners only do digits (0-9), so if you are in fact using a bar code scanner, bar codes can only be digit strings. Note: ASCII is generally a proper subset of most UTF-8 character sets, esp. for Latin character sets.

  6. mhustings
    Member
    Posted 1 year ago #

    Ugh, Windows strikes again, eh? Unfortunately, this is the system I have to work with. Thanks for your further thoughts! We'll try to use text editors to save lists before uploading. With what you're saying (and past troubles I've had with MSWindows/Office character formatting) I bet this is what will work for us. Thanks again for all your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags