WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
[resolved] Bulk Upload Issues (18 posts)

  1. aedesigns
    Member
    Posted 1 year ago #

    I have a CSV with around 10,000 stores that I need imported. It takes quite a while for the import to go through and once it does, my screen goes blank. It also doesn't import all of the stores. I had to go through this several times before all of the stores were loaded.

    Now I am getting the following errors:

    Warning: Division by zero in /home/content/13/10446013/html/granitegoldtest/wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 596
    
    Warning: Division by zero in /home/content/13/10446013/html/granitegoldtest/wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 601
    
    Warning: Division by zero in /home/content/13/10446013/html/granitegoldtest/wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 601
    
    Warning: Division by zero in /home/content/13/10446013/html/granitegoldtest/wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 602

    On top of it, it will not show me my uncoded stores. The Manage stores tab seems to be completely broken. Can you help assist me with these issues?

    The site is: http://granitegold.com/granitegoldtest

    http://wordpress.org/extend/plugins/store-locator-le/

  2. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like your server has run out of memory trying to process all the locations at once. You need to look at your PHP and MySQL limits on the server. With 10,000+ locations you are going to need well over the default limits typical on most servers.

  3. hvck
    Member
    Posted 1 year ago #

    I may have a fix for this (??). At least it worked for me.

    I just started having the same problem and I am not bulk uploading. I am manually adding store locations and I have reached 31 records.

    Everything was ok until I started using the "Actions and Filters" fields. I was trying to filter on the name of a store which had a few different locations and when I clicked to see the filtered list I started getting errors:

    Warning: Division by zero in /wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 596
    
    Warning: Division by zero in /wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 601
    
    Warning: Division by zero in /wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 601
    
    Warning: Division by zero in /wp-content/plugins/store-locator-le/include/storelocatorplus-adminui_class.php on line 602

    (I've removed my root directory location for security sake.)

    The problem seems to have something to do with the page navigation routine and values coming from the database.

    In fact, I went into the wp_options table in MySQL and found a field called "sl_admin_locations_per_page" which was set to null. I changed it to 25 and now everything works properly, as before.

    Let me know if you need any other details.

  4. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @hvck - great info here... I will look at this and see what I can come up with for a patch.

  5. hvck
    Member
    Posted 1 year ago #

    Glad to help.

    A little more info -

    I tried to replicate the problem and in fact the error came back again when I tried to change the number of locations that are listed in the Manage Locations area. As soon as I changed the SELECT the page reloaded with errors. I went into the database and changed the field's value to 100 and when I reloaded that page it was indeed set to 100 locations per page, no errors.

    One more thing - the Search Locations field doesn't work at all for me. I've installed the plugin for the first time right now so I don't know if it worked in the past, but for me it does nothing. I enter a word and then click "Search Locations" and nothing happens.

    I don't know if others are having these problems as well or if it has something to do other plugins, but since we're talking about the Admin area I wouldn't think that conflicts should be a problem.

  6. leadology
    Member
    Posted 1 year ago #

    hvck thanks for the info. I had loaded in a few and everything was fine and I was happy with the plugin, so I went ahead and loaded in about 50 more locations all manually and the plugin did the same thing as you describe. I am going to try your fix.

    Thanks again:-)

  7. leadology
    Member
    Posted 1 year ago #

    hvck, one more thing...can you show the url you are using it on? Just curious how yours looks and works. Thank you:-)

  8. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    I am testing a fix in 3.8.18. I really messed up the manage locations with one simple line...

    print "blah" . $this->render_actionbar;

    The proper code?

    print "blah";
    $this->render_actionbar;

    There is a bit more to the fix to that, but that is the big one. 3.8.18 will be out after a quick test, if all goes well, later today.

  9. leadology
    Member
    Posted 1 year ago #

    charleston...just seeing your message about the update. I will hold off doing anything with the hopes that you will have a fast fix in 3.8.18 today. Thank you:-)

  10. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    3.8.18 update is out as of 10PM EST last night. You can force updates by doing "check updates" with WordPress.

    You can also follow development & release notices as they happen. I use FaceBook as my "daily update report" mechanism. The page should be public which means you don't need to like to see it (though likes bumps up my exposure, so I appreciate them).

    http://www.facebook.com/charlestonsoftwareassociates

  11. leadology
    Member
    Posted 1 year ago #

    Charleston, I have installed the update and the problem is gone!! Thank you so much for your diligence in fixing this problem. Now I can move on with my project:-)

  12. hvck
    Member
    Posted 1 year ago #

    It works for me as well. No more errors on number change and the other form fields are now working.

    Thanks.

  13. aedesigns
    Member
    Posted 1 year ago #

    Thank you very much for the update! I'm not receiving the same error although the show uncoded function is not working. I have several locations that are without lat & long and I just receive the following results: "No locations have been created yet" when clicking on it.

  14. aedesigns
    Member
    Posted 1 year ago #

    I called my hosting company and they said that my MySQL limits are set at 20MG. Any ideas why my screen keeps going blank during upload and of course not uploading all the data? My CSV is 1.1MG and it contains 9238 locations.

  15. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Possibly a PHP memory constraint on your server. Try a smaller load and see if that works. Split the file into a 2000 location piece and see what happens.

    The new bulk upload has a "skip duplicates" feature since 3.8.11 that will help if you need to split up the 9k file.

    Use the contact form at http://www.charlestonsw.com/mindset/contact-us/ and I can try the file as well and see how "show uncoded" works. 3.8.18 fixed a bug in the manage locations action bar, so if you are not on that release you may want to upgrade.

    http://www.charlestonsw.com/support/documentation/store-locator-plus/release-notes/release-notes-v3-8/

  16. aedesigns
    Member
    Posted 1 year ago #

    Thanks for your immediate response! There is no field to upload the file on your contact form. BTW- I upgraded this morning.

    I really need to be able to upload the entire file at once to make it easier for my client to manage.

    Can you explain to me the difference between the MySQL & PHP limits that my server has set to 20MG and what you are referring to?

  17. aedesigns
    Member
    Posted 1 year ago #

    I have the latest update and the "Show Uncoded" still displays 0 results when there are several.

    [No bumping. Your problems are no more urgent than anyone else's. If it really is that that urgent, consider hiring someone.]

  18. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic