WordPress.org

Ready to get started?Download WordPress

Forums

Media Rename
[resolved] Bulk rename doesn't update all attributes of image (WP 3.5) (6 posts)

  1. Mario Marzuki
    Member
    Posted 1 year ago #

    Dear ShadowsDweller,

    First of all, thank you for writing such a fantastic plugin which saves me hours and hours of work!

    I used the bulk rename functionality from within the Media Library page to rename my images. I'm using WP 3.5. This seems to be working (and all my Portfolio posts referring to those images also have their links updated), however, not all database attributes of the image have been updated. In particular, the file name field of the "original"/"fullsize" image as stored in the database is still showing as the old file name, even though the physical files themselves (original size) have been renamed on the server.

    This causes some plugins that refer to this field (e.g. Watermarking) to fail.

    Sorry it's a little hard to explain but I'm not able to include a screenshot in this support forum. If you could send me an email to Mario@marzuki.co.nz I'll be more than happy to send what actions I took and a screenshot of the final result?

    Many thanks again for your help and looking forward to hear from you.

    Kind regards,
    Mario

    http://wordpress.org/extend/plugins/media-rename/

  2. Mario Marzuki
    Member
    Posted 1 year ago #

    Just to be absolutely clear - the filename attributes of the thumbnail sizes (medium, small, etc) seem to have been updated just fine, and I didn't even have to regenerate the thumbnails in WordPress.

    Have a great day.

    Regards
    Mario

  3. Mario Marzuki
    Member
    Posted 1 year ago #

    Hi ShadowsDweller,

    I think I found out what the exact issue is. When using a Bulk rename functionality, the plugin seems to HAVE correctly:
    * Renamed the physical filenames
    * Updated the 'post_name' values of the media in wp_posts table to be the same as the new filename (without extensions)
    * Updated any references in existing posts to the old filenames

    However it did NOT seem to:
    * Update the 'guid' value of the media in wp_posts table so that it points to the new filename

    Therefore certain plugins or codes that still refer to this meta value to retrieve image information, fail to work.

    Hopefully this clarification helps.

    Regards
    Mario

  4. ShadowsDweller
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks for your donation!

    You are right, I don't update the GUID because I thought it was not a good idea, but as it seems I need to update it too. I will fix it in the next few days :)

  5. Mario Marzuki
    Member
    Posted 1 year ago #

    Hello,

    Sorry for the delay in following up but thank you very much for getting back at me! Glad the info I provided helped, looking forward to the updated version.

    Thanks again and keep up the great work!

    Kind regards,
    Mario

  6. ShadowsDweller
    Member
    Plugin Author

    Posted 1 year ago #

    Version 3.1 is out :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.