WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Bulk optimize not working (5 posts)

  1. Samuel Aguilera
    Member
    Posted 1 year ago #

    Hi!

    Nice plugin, saves a lot of time when you need to optimize an already uploaded image ;)

    Unfortunately bulk optimize is not working (at least for me).

    After pressing the "Start optimizing" button, it makes a server connection but after that nothing happens.

    Seems a JS issue, because after that, the WordPress hover submenus stopped working until you reload the page.

    Best regards!

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. ogenox
    Member
    Posted 1 year ago #

    Yeah, like you said, it's JS conflict with some plugins. However, if you install Google Libraries plugin, bulk optimize will work.

  3. Samuel Aguilera
    Member
    Posted 1 year ago #

    Well, this is a workaround more than a fix... but it's ok, it works.

    Thanks ;)

  4. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Just released 1.4.3 which should resolve the js errors. Most of them (I think), are caused by this plugin using the version of jquery included with the beta version of WP 3.6, which some plugins have trouble with. The whole point of loading jquery was to support older versions of WP, so I've added a version check to avoid loading jquery when WP is already loading a compatible version.

    I believe the Google Libraries plugin fixes things, because it reverts the jquery version to whatever WP would normally load.

  5. Samuel Aguilera
    Member
    Posted 1 year ago #

    Thank you! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic