WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Bulk optimization fails in Nextgen Gallery but manual optimization works (4 posts)

  1. solstyce9
    Member
    Posted 11 months ago #

    Having an odd situation on a personal site hosted on hostgator. In a NextGen Gallery the manual optimization of an image works, but bulk optimization fails with the error below. I tried enabling debug logging, but didn't see any additional errors appearing during optimize.

    I did a search but didn't see anything obviously applicable. Any suggestions?

    It's not a blocker since I can manually optimize, but should make life simpler if bulk worked.

    Error:---------------------

    Warning: require_once(<PATH HIDDEN>/public_html/wp-content/plugins/nextgen-gallery/lib/meta.php) [function.require-once]: failed to open stream: No such file or directory in <PATH HIDDEN>/public_html/wp-content/plugins/ewww-image-optimizer/nextgen-integration.php on line 379

    Fatal error: require_once() [function.require]: Failed opening required '<PATH HIDDEN>/public_html/wp-content/plugins/nextgen-gallery/lib/meta.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in <PATH HIDDEN>/public_html/wp-content/plugins/ewww-image-optimizer/nextgen-integration.php on line 379

    ---------------------------

    EWWW Status:
    Plugin Status

    If updated versions are available below, you may need to enable write permission on the wp-content/ewww folder to use the automatic installs.
    *Updates are optional, but may contain increased optimization or security patches
    jpegtran: OK version: Independent JPEG Group's JPEGTRAN, version 9 13-Jan-2013
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.70
    Graphics libraries - only need one, used for conversion, not optimization: GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  
    Only need one of these: finfo: MISSING  getimagesize(): OK  mime_content_type(): OK

    ---------------------------------

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

  3. solstyce9
    Member
    Posted 11 months ago #

    Doh. Sorry for wasting your time. I searched for the error message and didn't think to search for nextgen gallery.

    Thanks for all your hard work!

  4. nosilver4u
    Member
    Plugin Author

    Posted 10 months ago #

    It's fixed in the dev version.

    I'm adding some new features, and kind of stalling a bit hoping we can get full support working in NextGEN 2 before I release the next version (waiting on the devs at Photocrati, but they're frightfully busy, so it might be a while).

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.