WordPress.org

Ready to get started?Download WordPress

Forums

[bug]Permalinks not working with non-English title (8 posts)

  1. Jeffrey
    Member
    Posted 4 years ago #

    If I use "Day and Name" or other non-default options as the Permalinks for my non-English blog, and if the post title is English, then everything is fine; but if the post title is non-English, then if you click the post title, the content is breaking and the comment box will disappear.

    I use UTF-8 as the default encoding for my WP blog.

    Any help is highly appreciated.

    Jeffrey

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    A link to a page on your site demonstrating the problem might help.

  3. Jeffrey
    Member
    Posted 4 years ago #

    http://www.cedarparknotebook.net

    If you click on the first post which is English, then everything is displayed fine. But if you click the second post which is in Chinese, then the post will have a link called "Continue reading about.." at the end of the post, and also the comment box is not loaded up besides breaking my rating plugin.

    Thanks,

    Jeffrey

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    I'm not sure that the issue is but I think it lies in the theme, the Ratings plugin, the post content itself or all 3. I noticed that the Chinese post content doesn't incorporate any paragraph tags and that the Rating plugin isn't outputting the correct divs.

    Have you tried deactivating the Ratings plugin to see what effect that has?

  5. Jeffrey
    Member
    Posted 4 years ago #

    Thank you for your reply. I can confirm the problem is not relate to either the theme or the plugin. I tried many themes, but all gave me the same problem. I also deactivated the plugin, but it didn't help either.

  6. Jeffrey
    Member
    Posted 4 years ago #

    Anyone, please? I have to switch back to the default permalinks setting so that my visitors can leave comments. Ugh..

  7. Okay, the problem is not WordPress really. I mean... Kinda sorta. It's that they're show as entities, and not the 'words' they are, because we're all viewing them in English. It's ... yeah. In theory if your language on your PC is set to Chinese, it works fine (never tested that myself, when I was in Japan I used English).

    So you get these options:
    1) Post titles in Chinese and forget the English.
    2) Post titles in English and support everyone
    3) Ugly Permalinks

  8. Jeffrey
    Member
    Posted 4 years ago #

    I finally found out that it was caused by the fact that my hosting plan is Windows which does not provide URL rewrite. I changed my hosting plan to Linux and everything is ok now.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.