WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Bug: wp-super-cache fails to keep the cache of search pages (7 posts)

  1. talgalili
    Member
    Posted 1 year ago #

    I'm using wp-super-cache version 1.3.1 with WP 3.5.1.

    I see that my search pages are cached, but if I re-visit the page after a few seconds - it is clear that a new search page was cached (by looking at the timestamp at the bottom of the source).

    For example see:
    http://www.r-bloggers.com/search/hadoop

    What I've looked at to resolve this:
    1) None of the "Accepted Filenames & Rejected URIs" are marked (but the "feed" but I tried with and without it and it didn't make a difference)
    2) I'm using Use mod_rewrite to serve cache files. I've tried switching to "Use PHP to serve cache files.", and it didn't help
    3) I tried "lock down" - it didn't help.
    4) I've tried "Directly Cached Files" for the search URL, it didn't help.
    5) I've had the "Don’t cache pages with GET parameters. (?x=y at the end of a url)" - checked and unchecked - it didn't help.
    6) I'm using preload content - doesn't help.

    I think this is a bug, any suggestions on what to do?

    Thanks.
    Tal

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. talgalili
    Member
    Posted 1 year ago #

    Interesting, I have another lead on this bug.
    I notice that the ?s=something will be cached (without being erased every time I search again), whereas /search/something WILL be re-cached everytime searched.

    For example, compare these two pages:
    http://www.r-bloggers.com/?s=hadoop
    http://www.r-bloggers.com/search/hadoop

    Is this a bug in the plugin, or something with my setup?

    Thanks upfront,
    Tal

  3. talgalili
    Member
    Posted 1 year ago #

    ping.

    I would love to have a cache of a search page keep without being refreshed, but I can't seem to force it on the system.
    Any suggestions?

  4. jondaley
    Member
    Posted 1 year ago #

    Are the supercache entries in your .htaccess, and are they being used? (you could try purposely putting an error in one of the lines, and see if it breaks everything).

    I see that the file is being regenerated every time.

    Is the cached file being created in /wp-content/cache/supercache/sitename/search/hadoop/index.html?

    I would try turning on the debugging, and look in the log file to see what it says.

  5. jondaley
    Member
    Posted 1 year ago #

    Hrm - I just realized, I've been doing a lot of work on lighttpd and not on apache, so I think my comments aren't relevant to the .htaccess file that comes with supercache. There are a couple entries in there that don't make any sense to me, and one of them is the issue you are having.

    By default, supercache doesn't cache any posts with a GET parameter due to the .htaccess rule that filters all of them out. You'd have to remove that check to make it work properly. In my lighty installation, I'm using my own rewrite.lua script, and so I ignore the GET parameters there.

    My previous comment regarding if your file is a static file is still correct though, that works whether supercache supports it or not.

  6. talgalili
    Member
    Posted 1 year ago #

    Dear jondaley - I wanted to say that I appreciate your response and help.

    I see that work is being discussed on .htaccess optimization. I'll wait for the next release and see what is left once the dust settles.

    With regards,
    Tal

  7. jt70
    Member
    Posted 1 year ago #

    Hi Talgalili,

    I was/am having a similar problem. Whenever a new comment is moved from the pending comments list it was clearing the cache. I had a lot of spambots patrolling my pages, and they were setting up pingbacks that went into the spam folder, clearing the cache. I turned off pingbacks to prevent this and the purges dropped dramatically. If you get a lot of spam, this might be what is going on.

    I still have a problem that whenever I publish/update, the cache is purged also. Haven't figured that one out yet. At least this might give you a place to start looking to see if this is the same issue.

    Good luck.
    Jeff

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic