WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] [BUG] Widget Title (6 posts)

  1. burgiuk
    Member
    Posted 1 year ago #

    Hello

    I updated the NextGEN Gallery plug-in this morning. It automatically includes a title on the slideshow widget even if you do not want one on the slideshow.

    To get round the problem I have specified that the title is a single space.

    John

    http://wordpress.org/plugins/nextgen-gallery/

  2. VesaT
    Member
    Posted 1 year ago #

    Yes, noticed the same if you leave the "Title" box empty on the widget. Then it displays text "Slideshow", but actually it should not display even the title element (widget title box).

  3. burgiuk
    Member
    Posted 9 months ago #

    This is still an issue in the latest version. My original work-around is no longer working.

    The issue is in \products\photocrati_nextgen\modules\widget\templates\display_gallery.php

    The actual problem is within the following code.

    echo $settings['widget_setting_before_widget']
         . $settings['widget_setting_before_title']
         . $settings['widget_setting_title']
         . $settings['widget_setting_after_title'];

    You need to test if $settings['widget_setting_title'] is blank. In my testing it returns a string length of 6 if you don't enter a widget title. I didn't dig any further into the code to work out where it was adding this mystery characters.

    John

  4. tizz
    Member
    Posted 9 months ago #

    @burgiuk The titles in the widgets has always been in that way, automatically added, in all the WordPress widgets with title, not only in Nextgen one.
    Time ago I worked around this using the ascii character alt+255.
    Now, a single hit on spacebar is enough, as it seems to me that you say too in the first post, but it's not a Nextgen's bug, it's the same for WP standard calendar, categories and so on widgets.

  5. burgiuk
    Member
    Posted 9 months ago #

    @tizz
    The single nomal space or nbsp no longer removes the widget title. Somewhere along the line the title varible is being populated with six blank characters.

    Because the title is now not empty it displays the title, wrapped in <h3> tags in my case.

    No other plugin is adding these extra characters to the title. As a temporary fix I have just removed the following from the widget template.

    . $settings['widget_setting_before_title']
         . $settings['widget_setting_title']
         . $settings['widget_setting_after_title']

    edit: formatting issue

  6. tizz
    Member
    Posted 9 months ago #

    The single nomal space

    For me works, with only a single space with spacebar. This behavior is common to all WP standard widgets.
    If you wanna check, look at the site in my name, at the bottom in the footer. In the middle there's nextgen slideshow widget where I removed the title with a single space.
    Usually the first time doesn't works. If I leave that field empty and save, title appears. But if I open again that widget, put a space and save, the title disappears.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic