WordPress.org

Ready to get started?Download WordPress

Forums

WP Minify
[BUG REPORT] WP 3.5 / PHP 5.2 / 000webhost (1 post)

  1. mAsT3RpEE
    Member
    Posted 1 year ago #

    Dear Sir,

    After some testing I have found the following errors in your code.

    1) WP-Minify uses minify engine. I hope you frequently update it as it can have errors. ie

    http://www.securityfocus.com/bid/52672/exploit

    2) WP-Minify breaks if the following values are set in wp-config.php with a trailing slash. but works fine if not

    THIS WORKS
    define('WP_CONTENT_DIR', '/home/username/public_html/wp_content' );
    define('WP_CONTENT_URL', 'http://www.example.com/wp_content' );

    THIS DOES NOT
    define('WP_CONTENT_DIR', '/home/username/public_html/wp_content/' );
    define('WP_CONTENT_URL', 'http://www.example.com/wp_content/' );

    I would suggest testing if WP_CONTENT_DIR and URL have trailing slashes if using it breaks the plugin

    3) Some servers get an error when using wp minify with the following error:

    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/usr/local/apache/htdocs) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in /home/username/public_html/wp_content/plugins/wp-minify/min/lib/Minify/Controller/MinApp.php on line 107

    I have fixed this problem by manually setting in min/config.php (line 65)

    $min_documentRoot = '/home/username/public_html/';

    To be honest I think it really sucks to not be able to specify the caching directory. I would really appreciate it if you could code this in some time.

    http://wordpress.org/extend/plugins/wp-minify/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic