WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Plugin breaks Sticky Posts in custom WP_Query() and query_posts() (12 posts)

  1. bechster
    Member
    Posted 8 months ago #

    The Events Calendar plugin seems to break the sticky posts option in normal WordPress posts when they are retrieved with a custom WP_Query() or query_posts().

    In the front page template of my web site I have two loops, thus I need one of the above mentioned methods. However, some time after upgrading The Events Calendar plugin to version 3, I started noticing that sticky posts didn't stick to the top on my front page anymore.

    I tried deactivating my plugins one by one. Not until I deactivated The Events Calendar did the sticky posts start to show up again.

    Sticky posts seem to show up as they are supposed to in the default loop, though.

    My front page is here (in Danish): http://horsensbibliotek.dk/

    My blog is here, top post is sticky (at the time of writing): http://horsensbibliotek.dk/artikler

    Can you please fix this in an upcoming release? In the meantime, do you have any idea as to how I can solve this problem?

    Thank you.

    http://wordpress.org/plugins/the-events-calendar/

  2. Jowy92
    Member
    Posted 7 months ago #

    Same problem here, The Event Calendar is blocking the sticky posts on http://www.jeuxenpromo.com

    I desactivate it unless the problem was fixed.

  3. bechster
    Member
    Posted 7 months ago #

    Others have this problem too:
    http://wordpress.org/support/topic/event-calendar-stops-sticky-posts-working-with-woo-canvas?replies=3#post-5025375

    It is giving me a bit of trouble, though, so I hope someone can come up with solution soon. Thanks.

  4. Barry Hughes
    Member
    Plugin Author

    Posted 7 months ago #

    Thanks all, I can certainly see the problem at work and we'll get this on the issue tracker and fix it as quickly as we can.

  5. leahkoerper
    Modern Tribe Support Rep
    Plugin Author

    Posted 7 months ago #

    Hi there,

    Thanks for reporting this issue. We were not able to get a fix into our forthcoming 3.4 release. However, this issue is still definitely a priority for us and we plan to work on it for an upcoming release. We will update this thread at that time. Thank you for your patience.

    Best,
    Leah

  6. bechster
    Member
    Posted 5 months ago #

    Hi,

    Please excuse my impatience, but I just can't help asking. Is this issue still somewhere in the pipeline? I really do miss my sticky posts. :)

    Thanks again.

  7. leahkoerper
    Modern Tribe Support Rep
    Plugin Author

    Posted 5 months ago #

    Hi bechster,

    We don't have an exact release date, but this has definitely been a priority for us. Stay tuned! We will update this thread when the fix is ready. Thank you for your patience!

    Best,
    Leah

  8. Barry
    Member
    Plugin Author

    Posted 5 months ago #

    Hi! We've now completed some work that ought to address this issue in our very next upcoming release. Thanks for your patience and if you do hit any further problems with this once you've updated please don't hesitate to let us know in a new thread - thanks

  9. Ciao Lunigiana
    Member
    Posted 5 months ago #

    Thanks. It seems to work fine now.

  10. leahkoerper
    Modern Tribe Support Rep
    Plugin Author

    Posted 4 months ago #

    Awesome, thanks for confirming Ciao Lunigiana!

  11. bechster
    Member
    Posted 4 months ago #

    Hi,
    It works. Thanks for fixing this issue. :-)

  12. leahkoerper
    Modern Tribe Support Rep
    Plugin Author

    Posted 4 months ago #

    Thanks for letting us know bechster! And thanks for your patience while we got it fixed.

Reply

You must log in to post.

About this Plugin

About this Topic