WordPress.org

Ready to get started?Download WordPress

Forums

Page Builder by SiteOrigin
Bug page builder (14 posts)

  1. shampooineur
    Member
    Posted 7 months ago #

    Hi everyone

    when in write a text with pages builder, i click on not create paragraph, i save.
    then when i try to modify a word...all the text is moved and its automatically select on create a paragraph in widget text edit.

    an idea ?

    https://wordpress.org/plugins/siteorigin-panels/

  2. Greg Priday
    Member
    Plugin Author

    Posted 7 months ago #

    Hi shampooineur

    That is rather strange. Are you running the latest version of Page Builder (1.4.4)? Can you check if you're getting any Javascript errors when creating a page?

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors#Step_3:_Diagnosis

  3. shampooineur
    Member
    Posted 7 months ago #

    Yes iam in 1.4.4
    Its not an error its an advertisement :

    Invalid CSS property declaration at: *

    what does it means ?

    thanks

  4. shampooineur
    Member
    Posted 7 months ago #

    its an copy of the "error"

    .flexslider .flex-control-nav li {
    *display: inline;
    display: inline-block;
    margin: 0 0 0 5px;
    zoom: 1;
    }

    .flexslider .flex-control-nav li:first-child {
    margin: 0;
    }

    .flexslider .flex-control-nav li a {
    width: 10px;
    height: 11px;

    background: url(theme/bg_control_nav.png) no-repeat 0 0;
    cursor: pointer;
    display: block;
    text-indent: -9999px;
    }

    .flexslider .flex-control-nav li a.flex-active {
    background-position: 0 bottom;
    cursor: default;
    }

  5. Greg Priday
    Member
    Plugin Author

    Posted 6 months ago #

    That CSS issue shouldn't be causing much of a problem with Page Builder. @froelandt, if you're getting the same issue, can you check if you're getting any JS errors?

    Just create a text widget, edit it, then click done and check for any JS errors.

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors#Step_3:_Diagnosis

  6. shampooineur
    Member
    Posted 6 months ago #

  7. froelandt
    Member
    Posted 6 months ago #

    Thanks for your support, Greg.

    This is what I get in the console :

    body.scrollTop is deprecated in strict mode. Please use 'documentElement.scrollTop' if in strict mode and 'body.scrollTop' only if in quirks mode. page_context.js:225
    body.scrollLeft is deprecated in strict mode. Please use 'documentElement.scrollLeft' if in strict mode and 'body.scrollLeft' only if in quirks mode. page_context.js:225
    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

    The problem happen when I create widgets using Page Builder. Once I have created all my widgets and unchecked all the "Automatically add paragraphs" checkboxes, I save my page and then all widgets checkbox "Automatically add paragraphs" except the last one I unchecked [!] go back to checked status. This happen to when I modify the page.
    This cause me a problem because I have a lot of custom html/php widgets using Bootstrap Theme tags.

    I installed the plugin wpautop (http://blog.bigsmoke.us/tag/wpautop-control/) to be able to globally disable the "Automatically add paragraphs" function on my website but I noticed no change, the problem is still there.

  8. shampooineur
    Member
    Posted 6 months ago #

    i download an old version of pages builder 1.4

    all is fine Now

  9. froelandt
    Member
    Posted 6 months ago #

    The problem seems related to version 1.4.4 as I noticed it immediately after updating from a 1.4.3 version to the last one.

  10. froelandt
    Member
    Posted 6 months ago #

    I encountered a new error (white screen on saving the page) after migrating my website from local to online. Here is the error I get after switching WP_DEBUG to true :
    'Fatal error: Cannot use object of type WP_Error as array in C:\inetpub\wwwroot\Wordpress\wp-content\plugins\siteorigin-panels\inc\copy.php on line 38'

    Any idea?

  11. Greg Priday
    Member
    Plugin Author

    Posted 6 months ago #

    That's an error that sometimes comes up. There are 2 options. Either you can disable the copy content setting, or you can use the latest development version.

    http://siteorigin.com/wp-content/uploads/2014/02/siteorigin-panels.trunk_.06.02.2014.zip

    You'll need to delete the current version of Page Builder before installing this development version.

    The fix will be in version 1.4.5, when that's ready.

  12. froelandt
    Member
    Posted 6 months ago #

    I tried both disableing the copy content setting and using latest dev version you provided, it still doesn't keep properly the check/uncheck status of each widget.
    I went back to version 1.4.3 and the error is now gone. I think i'm gonna stay on this version until 1.4.5 is released with this bug fixed. Thank you for your great support and let me thank you again for this awesome plugin that makes me save a lot of time on building complex pages ! :-)

  13. Greg Priday
    Member
    Plugin Author

    Posted 6 months ago #

    Yeah, the development version would only fix that fatal error. I'm still working on this checkbox issue.

    Would it be possible for anyone having this issue to give me a list of plugins that you have installed? I'll see if I can find a conflict.

  14. froelandt
    Member
    Posted 6 months ago #

    Here is the list of all my plugins :

    • Admin Menu Editor Version 1.3.1  desactivated
    • Akismet Version 2.5.9  desactivated
    • Allow PHP in Posts and Pages Version 3.0.4  desactivated
    • BackUpWordPress Version 2.4.3
    • Bootstrap Shortcodes Version 2.1  desactivated
    • Custom Login Version 2.2.3
    • Custom Post Templates Version 1.5 desactivated
    • Custom sidebars Version 1.4
    • Easy Modal Version 1.3.0.3 
    • Formidable Version 1.07.04 
    • Formidable Bootstrap Version 1.0b2
    • Page Builder by SiteOrigin Version 1.4.3
    • Page Restrict Version 2.1.2 
    • PHP Code Widget Version 2.2
    • Sideways8 Private Pages Version 0.8.2 
    • Video.js - HTML5 Video Player for WordPress Version 4.3.1
    • WP-Filebase Pro Version 3.1.12
    • wpautop-control Version 1.0 
    • WP Hide Dashboard Version 2.2
    • WP SMTP Version 1.1.6

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.