WordPress.org

Ready to get started?Download WordPress

Forums

Nextend Google Connect
[resolved] Bug: Login/link with Google is no longer working (24 posts)

  1. renet
    Member
    Posted 1 year ago #

    I just updated to the latest version of your plugin and it seems that you kinda messed up the Google login. Can you please take a look. When clicking the button, I get redirected to the same page (or the home page, if I used the buttons in the login form), but without being logged in / linked.

    A bit more QA for future releases would be appreciated! ;)

    http://wordpress.org/extend/plugins/nextend-google-connect/

  2. veribo
    Member
    Posted 1 year ago #

    I've got the same problem. The plugin stopped working. I click on the Connect button, i log in as usual, but then i get redirected back to the site and i'm not logged in.

  3. dogriad38370
    Member
    Posted 1 year ago #

    Same here !

  4. ecrip
    Member
    Posted 1 year ago #

    Guess I should have looked much here earlier. Spent the last several hours trying to figure out why the Google log-in wasn't working correctly.

    Same problem as veribo and renet. The Google button takes me back to the homepage but without being logged in / linked.

    Thanks!

  5. markgthorne
    Member
    Posted 1 year ago #

    Same here

  6. science0101
    Member
    Posted 1 year ago #

    +1

  7. shecky
    Member
    Posted 1 year ago #

    I have find the problem, guys!!!

    - Open file nextend-google-connect.php.
    - Find in row 265 ( function new_google_login_action() ) this code:

    }
      new_google_redirect();
    }

    - and replaced with

    } else {
    	$authUrl = $client->createAuthUrl();
    	header('Location: ' . filter_var($authUrl, FILTER_SANITIZE_URL));
    	exit;
      }
      new_google_redirect();
    }

    The plugin will return to work properly!!!

  8. maddogmcewan
    Member
    Posted 1 year ago #

    applied fix above - still no go - get error500

  9. djvibe
    Member
    Posted 1 year ago #

    yeah I tried and it didnt work for me either.

  10. shecky
    Member
    Posted 1 year ago #

    Fix in my site works... :-(
    Try to delete and recreate the Google application ;-)

  11. MakaanPL
    Member
    Posted 1 year ago #

    @shecky - Your solution works also in my site. Thanks!

  12. Martin
    Member
    Posted 1 year ago #

    damn, i just found out this plugin hasn't been working for some time which is kinda bothersome.

    Tried the fix above but get an error also:

    The redirect URI in the request: http://www.geekandjock.com/wp-login.php?loginGoogle=1 did not match a registered redirect URI

    Any other ideas since the developers seem to have gone missing on this?

  13. shecky
    Member
    Posted 1 year ago #

    Martin, error is caused by incorrect configuration of the Google application, not from plugin.
    Apply the fix I wrote above and delete and recreate the Google application: everything will work properly ;-)

  14. Greg Priday
    Member
    Posted 1 year ago #

    @shecky, your fix worked perfectly for me. Thanks a million.

  15. RalphGL
    Member
    Posted 1 year ago #

    Login on the demo site http://www.nextendweb.com/wp-login.php with a google account (chrome browser windows 7) does not work as it does not work on my own WP Site. Will you fix the problems some day?

  16. Martin
    Member
    Posted 1 year ago #

    @shecky and all:
    Well, I finally got around to revisiting this.
    Deleted the Google App and did another per instructions.
    All is working again.
    No idea what happened as it was working before. Proves the plugin is fine and functional.

  17. DrMosko
    Member
    Posted 1 year ago #

    i did the sulotion, and woks fine it stopped redirect to my home page and went to goole coonect but after connection approval from google the user go back to the site with this error:
    Catchable fatal error: Object of class W3_Redirect could not be converted to string in /home/ilnetwor/public_html/wp-content/plugins/nextend-google-connect/nextend-google-connect.php on line 444

  18. DrMosko
    Member
    Posted 1 year ago #

    i think the problem is here:
    get_category_parents - is empty as mentioned in this post

    <?php if(is_home() OR is_front_page()) {} else { ?>
    <h1 class="page-title">
    <?php if(is_search()) { ?>
    <?php echo $wp_query->found_posts; ?> <?php _e('search results for', 'gp_lang'); ?> "<?php echo esc_html($s); ?>"
    <?php } elseif(is_category()) { ?>
    <?php $catstr = get_category_parents($cat, false, ' / '); echo substr($catstr, 0, strlen($catstr) -3 ); ?>
    <?php } elseif(is_tag()) { ?>
    <?php single_tag_title(); ?>
    <?php } elseif(is_author()) { ?>
    <?php wp_title(''); ?>'s Posts
    <?php } elseif(is_archive()) { ?>
    <?php _e('Archives', 'gp_lang'); ?> <?php wp_title(' / '); ?>
    <?php } ?>
    </h1>
    <?php } ?>

  19. bigun66
    Member
    Posted 1 year ago #

    @scheky's solution worked perfectly for me.

    Make sure you use a text editor that shows line numbers, so you can find Row 265 in nextend-google-connect.php.
    This is a big file, and there is more than one line with the following function call:
    function new_google_login_action()
    So be careful you're only changing the one on line 265.

    Several people have mentioned deleted and adding the "Google Application". I needed to do this also before the fix worked.
    More precisely, I deleted and re-created my "Client ID for web applications", which is in the API Access tab at https://code.google.com/apis/console

    Thanks to @scheky!!!

  20. Martin
    Member
    Posted 12 months ago #

    It seems that the connect part still works with the fixes described above but the avatar image import is broken. I now see a broken image in all places the profile image should be.
    Thoughts?

  21. nextendweb
    Member
    Plugin Author

    Posted 11 months ago #

    Hey guys! Sorry, I was really busy in the last months. The plugin should work fine for now in version 1.4.54

  22. RalphGL
    Member
    Posted 11 months ago #

    Thank you very much, nextendweb!
    Sometimes it is a good idea to wait patiently!
    After updating the plugin is working fine without any patches.

  23. Jaber Al Nahian (rijans)
    Member
    Posted 11 months ago #

    I get the following error:

    Catchable fatal error: Object of class W3_Redirect could not be converted to string in /home/techgain/public_html/wp-content/plugins/nextend-google-connect/nextend-google-connect.php on line 452

    Login link
    http://www.techgainer.com/wp-login.php

    And why the button doesn't show up? It only shows link!

  24. rodrigo2017
    Member
    Posted 3 months ago #

    nos dois plugins, para o gmail e para o facebook, eu tive o seguinte problema. após uma pessoa logar se registrar e logar pelo gmail ou pelo facebook, após sair , quando tentamos logar com outro usuario pelo facebook ou pelo gmail, o programa abre a sessão antiga com o usuário que estava logando antes ....
    alguém pode testar e ver se acontece isso também ????

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.