WordPress.org

Ready to get started?Download WordPress

Forums

[BUG] Linebreak automatically added even using non-WYSIWYG editor (4 posts)

  1. ceefour
    Member
    Posted 7 years ago #

    Try typing:

    hello
    my
    friend

    in non-WYSIWYG editor.

    It will result just like what you typed it. According to HTML, it should print "hello my friend", without line breaks, since it doesn't contain
    .

    This makes it very inconvenient, e.g. to compose your article in a HTML editor, then copy & paste in WordPress's non-WYSWIYG editor, then find out that your posts has unwanted linebreaks all over it.

  2. spencerp
    Member
    Posted 7 years ago #

    Please! If you have various bugs in the RTE or whatever.. keep them all in one thread! Anyway.. post the bugs over here: http://trac.wordpress.org/ Good luck!

    Also, join one of these email lists.. and post the problems there as well.
    http://lists.automattic.com/mailman/listinfo/wp-testers
    http://lists.automattic.com/mailman/listinfo/wp-hackers

    spencerp

    /Replying with the same response as the first one, to keep them outta the dang "no-replies" section.. Also, to keep a descent reply for future reference purposes.

  3. Barneyk
    Member
    Posted 7 years ago #

    Yes, wordpress messing with linebreaks is really annoying...

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    That's not a bug, it's a feature. WordPress automatically inserts linebreaks and paragraph markers and such to make your post look more or less what like what you think it should be. Not everybody knows HTML.

    If you want to disable this behavior, use this plugin:
    http://ottodestruct.com/wpstuff/disableautop.zip

Topic Closed

This topic has been closed to new replies.

About this Topic