WordPress.org

Ready to get started?Download WordPress

Forums

Bug killer needed for new theme (please) (1 post)

  1. lilszard
    Member
    Posted 6 years ago #

    My site: Aunty Lomi

    Hiya!

    While I'm somewhat comfortable with .css, I'm completely new to .php, so I'm having trouble figuring out where I went wrong with my theme design. Please help...

    1. First issue: If I try to add an image file (including the adsense ads) into my content (post), the banner ad at the bottom of my page disappears and my footer content floats up somewhere near the header (as if the image file cancelled out index.php...?)

    2. Next: When I try to split my post with the 'more' tag, the post doesn't show up at all. Only the content header and the link 'Read more here' shows up. In other words, what's wrong with this code?

    <div id="content-head" id="post-<?php the_ID(); ?>">
    
    <a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></div>
    
    <div class="smtext"> Posted <?php the_time('F jS, Y') ?> by <?php the_author() ?> </div>
    
    <?php the_content('Read More'); ?> 
    
    <div id="read-more"> <a href="<?php the_permalink(); ?>" rel="bookmark">  What do YOU think?</a></div>
    
    <div id="comment-head" style="font-size: 11px;"><?php the_tags('Tags: ', ', ', '<br />'); ?> Posted in <?php the_category(', ') ?> | <?php edit_post_link('Edit', '', ' | '); ?>  <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?></p></div>

    I have a feeling solving these two issues will sort out any other glitch I've come across.

    Thanks HEAPS in advance for any assistance you can offer.

Topic Closed

This topic has been closed to new replies.

About this Topic