WordPress.org

Ready to get started?Download WordPress

Forums

wpMandrill
[resolved] Bug in WP-Mandrill Settings (6 posts)

  1. baritoneuk
    Member
    Posted 1 year ago #

    There is a problem with one part of the form on the WP-Mandrill settings page- under "General Design".

    <input name="wpmandrill[nl2br]" type="checkbox" <?="checked($nl2br,1);" ?=""> value='1'

    It looks like PHP hasn't been closed properly or you're trying to use short PHP tags. Here is a screenshot:

    https://dl.dropbox.com/u/95261/mandrill.png

    http://wordpress.org/extend/plugins/wpmandrill/

  2. baritoneuk
    Member
    Posted 1 year ago #

    Ah, I can see from someone else's thread in this forum that the problem could be to do with your use of php short tags. My server doesn't allow short tags at all, and I am sure I am not alone in this. Could you please update the plugin to use proper long php tags, otherwise the plugin just breaks.... :-(

  3. baritoneuk
    Member
    Posted 1 year ago #

    Just gone through the code in wpmandrill.php and changed all the <?= to <?php echo and it works fine. It would be great if you could update the code to this for future versions.
    Thanks.

  4. Ovidiu
    Member
    Posted 1 year ago #

    Didn't seem to work for me. How many occurrences did you find?

  5. baritoneuk
    Member
    Posted 1 year ago #

    I don't know how many for sure, I just did a page find and replace swapping all '<?=' into '<?php echo' on the wpmandrill.php file.

  6. MC_Will
    Member
    Plugin Author

    Posted 1 year ago #

    Solved in v1.27. Sorry for the inconvenience!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.