WordPress.org

Ready to get started?Download WordPress

Forums

Sweet Captcha
[resolved] Bug in the code (2 posts)

  1. Hakk1tus
    Member
    Posted 1 year ago #

    If you wonder why sweetcaptcha shows form even you have selected function "Omit captcha for registered users:"

    Original lines would look like this:

    Line 65
    if ( get_option( 'sweetcaptcha_form_ommit_users' ) && isset($user_ID) && (int)$user_ID > 0 ) {

    and

    Line 88
    if ( get_option( 'sweetcaptcha_form_ommit_users' ) && isset($user_ID) && (int)$user_ID > 0 ) {

    If you want to get that function work properly just remove those extra m-letters on the word ommit. So new lines should look like this:

    Line 65
    if ( get_option( 'sweetcaptcha_form_omit_users' ) && isset($user_ID) && (int)$user_ID > 0 ) {

    and

    Line 88
    if ( get_option( 'sweetcaptcha_form_omit_users' ) && isset($user_ID) && (int)$user_ID > 0 ) {

    even you do all this it will show the captcha on the contact form 7 (if used). I would like to get option for that to hide it from the registered users.

    Best Regards
    Hakk1tus

    http://wordpress.org/extend/plugins/sweetcaptcha-revolutionary-free-captcha-service/

  2. Sweet Captcha
    Member
    Plugin Author

    Posted 8 months ago #

    Please update your Sweet Captcha plugin, contact us at support@sweetcaptcha.com if your issue persists

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.