WordPress.org

Ready to get started?Download WordPress

Forums

WP-DBManager
[resolved] Bug found - sending backup to nonexistent addresses (10 posts)

  1. utnalove
    Member
    Posted 6 months ago #

    Hello, I noticed a problem long time ago.
    But just today I analyzed and grep the file and databases and found the issue.

    The problem is that since december 2013 I can see that in the backup I receive I see the following header in the email:

    Until December 2013 it looked like this:

    from:	 MY OLD BLOG TITLE Administrator myblogmainemailaddress@mydomain.com
    to:	 myrealemail@gmail.com

    These were the headers I was receiving before moving to a VPS - here I was in a shared server. This kind of header started to appear from December 2013:

    from:	 myemail@gmail.com
    reply-to:	 XXX@theserveraddress.com,
     YYY Administrator <myblogmainemailaddress@mydomain.com>
    to:	 myrealemail@gmail.com

    Since I am in the VPS now I see the following:

    from:	 MY.BLOG.TITLE.|.Blog.XXX@localhost.localdomain
    reply-to:	 MY.BLOG.TITLE.|.Blog.XXX@localhost.localdomain,
     XXX@localhost.localdomain,
     YYY Administrator <myblogmainemailaddress@mydomain.com>
    to:	  myrealemail@gmail.com

    What was the difference between before december 2013 and after dec 2013?
    The blog title.

    Until dec 2013 the blog title was very simple... like this:
    "My old blog title"

    From dec 2013 the new blog title is:
    "MY BLOG TITLE | Blog ZZZ, XXX, YYY"

    It looks like that the plugin is taking the word XXX from the tile and uses it as a reply to address. And uses YYY as the name of the administrator.

    I have conserved the structure.
    If you give me a contact or whatever I can send you the right (real) names and email addresses.

    Would you be able to fix it?

    https://wordpress.org/plugins/wp-dbmanager/

  2. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    I have not change the way the plugin emailed for ages. And on my on VPS I am not seeing "XXX@localhost.localdomain", so I am guessing it is added by your own VPS PHP mailer or it was not configured correctly.

    Also WP-DBManager does not set the reply-to header because it is meant to send you a backup and not reply to it.

  3. utnalove
    Member
    Posted 6 months ago #

    Hi, I have noticed it in 3 different places.
    I have a shared hosting at HostMonster
    I have shared hosting at StableHost
    and I have a VPS

    Everywhere is misconfigured??? If you mean the FQDN yes, this has to be configured in the VPS... this is white localhost.localdomain. But in the shared hosting the right domain name appear.

    If the blog title on "wp-admin/options-general.php" is set to MY BLOG TITLE | Blog ZZZ, XXX, YYY then the problem appears.

    If the blog title is set to a simple few words phrase, it works fine.

    If you think that what I wrote above (that 3 different servers all have the same problem) is not enough, then I can say that the bug is different.

    According to $mail_header = 'From: '.wp_specialchars_decode(get_option('blogname')).' Administrator <'.get_option('admin_email').'>';
    the email from should be
    MY BLOG TITLE | Blog ZZZ, XXX, YYY Administrator <theemailtotheadministrator@therightdomain.com

    But if I use that title (with pipe and commas) the from appears as
    MY.BLOG.TITLE.|.Blog.ZZZ.
    So XXX and YYY are striped out from the title. And all spaces and commas are turned into dots .

  4. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks, filed it as a bug https://github.com/lesterchan/wp-dbmanager/issues/3, will fix it when I am free

  5. utnalove
    Member
    Posted 6 months ago #

    Thank you. I have 3 more questions:

    1) Would it be possible to make the sending email script to be compatible as the rest of php mail() plugins? I mean... I have WP-MAIL-SMTP http://wordpress.org/plugins/wp-mail-smtp/, but even though other plugins (when wp mail smtp is on) start sending emails via SMTP with all the fields I configured in smtp, WB-DBMANAGER still keeps sending emails via php script and for some reason bypassing wp-mail-smtp.

    2) If the answer to question 1 is no (I really hope you agree and it will be yes :), would it be possible to add in the db-options some customizable fields such as "from email" and maybe also subject?

    3) I did today my 1th little donation. I hope you received my coffee.

  6. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    I make a quick fix, it is just basically adding quote to the From header, you can try it here https://github.com/lesterchan/wp-dbmanager/archive/master.zip

    1) Yes I have plans to make use of wp_mail() instead of php mail() which will work with WP-MAIL-SMTP (based on the description). Just created a ticket https://github.com/lesterchan/wp-dbmanager/issues/4

    2) Any reason or use case for setting the from email and subject?

    3) Thank you!

  7. utnalove
    Member
    Posted 6 months ago #

    I have tried the version 2.66, and sent the backup to my email. But nothing seems to have changed in the email headers.

    1) Great. Thank you.

    2) This would help people that have multiple sites in a VPS and are not using "sendmail_path" to define the right email address for all the different domains. In this case they can configure their blogs to send a personalized email. Just for easier management.

  8. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    1) That is wierd, it works fine on my dev, when I email the backup to myself, I am seeing "From: "Lester Chan's WordPress Plugins Development | Blog ZZZ, XXX, YYY Administrator" <@gmail.com>" in the mail headers. Is the email sent from the cron or the email backup feature?

    2) Make sense, don't think that is difficult to implement https://github.com/lesterchan/wp-dbmanager/issues/5

  9. utnalove
    Member
    Posted 6 months ago #

    1) the emails are sent from wp-admin/admin.php?page=wp-dbmanager/database-manage.php

    If you want I can send to your email the right blog title I am using. So you can test it.

    2) Thanks

  10. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    Saw your email, lets take it there.

Reply

You must log in to post.

About this Plugin

About this Topic