WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] bug busting - 2nd domain mapped to root install (4 posts)

  1. Rhicreate
    Member
    Posted 2 years ago #

    I know this problem has been posted quite a bit on the forums, but I've tried most of the tips available and I'm not getting any results.

    I have a multisite install, which is only running 2 sites - and it's not going to get much bigger - I've used subdomain-mapping for the off shoots.

    I have a parked domain on my hosting that should be redirecting to the root site's domain, but I'm getting the redirection to sign up page whenever I type that other domain in. I've tried multisite domain plugin but it seems like overkill for only 1 domain - that I'm only retaining as it's still got a listing on google - i just need a 301 redirect really! The NOBLOGREDIRECT setting doesn't seem to work.

    Wonder if it has something to do with existing domain rewrite rules related to the www. non www mapping...? Can anyone help me debug/is there another way of doing it? I don't want anyone else to create subdomains and will only be using a select few myself, so I wondered if there is any way to 'limit' the wildcard - or set up a multisite differently so that only specific subdomains would be allowed?

  2. First off turn off the ability of everyone else to make a new site :) That's basic.

    /wp-admin/network/settings.php

    Change registration options.

  3. Rhicreate
    Member
    Posted 2 years ago #

    Thanks for your reply, the ability to create new sites WAS already turned off... but I went to that page anyway, and realised this morning that I had been having a dyslexic moment with the code in config.php and had been typing "BLOGNOREDIRECT" instead of "NOBLOGREDIRECT" - DUH!

    So it's fixed now, thanks for helping out though :)

  4. I swear I'm not laughing. I swear I never spent two days with a typo on a server name!

Topic Closed

This topic has been closed to new replies.

About this Topic