WordPress.org

Ready to get started?Download WordPress

Forums

YOP Poll
[resolved] Bug - Bad Request vote message. (13 posts)

  1. karehiqu
    Member
    Posted 7 months ago #

    Hello

    I love this plugin however during a few hours ago the poll is not working properly , When a user votes , There is a "Bad Request!" message.

    How can i solve this ?

    Regards

    http://wordpress.org/plugins/yop-poll/

  2. YOP
    Member
    Plugin Author

    Posted 7 months ago #

    Hi karehiqu,

    Please provide a link to your poll and mention exactly when the error appears so we may assist.

    Best wishes,

    YOP Team

  3. anefarious1
    Member
    Posted 7 months ago #

    Hello. I am getting the same result, "Bad Request!" appears at the top of the poll.

    My site is http://acafine.com/penalty-details/
    The poll is in the sidebar, right hand side. The error appears after a vote is placed.

    Thanks for your help.

  4. karehiqu
    Member
    Posted 7 months ago #

    The "Bad request" message is still apearing

    Check it out http://acafine.com/penalty-details/

    Also

    I would like to suggest That it would be so great if the poll were embeddable from third parties sites.

    Regards

  5. SolenergiDanmark
    Member
    Posted 7 months ago #

    Hi, I am also recieving the Bad request message when Im using IE og FireFox browsers. It works fine in Chrome, tho.

    The poll is located on http://www.solcelleloven.dk in the right bar

  6. YOP
    Member
    Plugin Author

    Posted 7 months ago #

    Hey,

    Can you please tell us if you use any cache plugins on your websites?

    Regards,

    YOP Team

  7. SolenergiDanmark
    Member
    Posted 7 months ago #

    We fixed it by deleting our cache in the wordpress.

  8. anefarious1
    Member
    Posted 7 months ago #

    I use WP Super Cache on ACAfine.com

    We fixed it by deleting our cache in the wordpress.

    Is that really a solution though because don't you have to keep doing it?

    Perhaps there is a setting to make within the cache plugin? Thanks

  9. YOP
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    Please edit inc/yop_poll_model.php and on line 3279, after

    public function return_poll_html( $attr = array( 'tr_id' => '', 'location' => 'page' ) ) {

    add

    define('DONOTCACHEPAGE',1);

    Next, delete the cache and run the pages that contain the poll for 2-3 times and see if the bad request message comes up again.

    Best wishes,

    YOP Team

  10. anefarious1
    Member
    Posted 7 months ago #

    The poll is on every page of the website so does this mean I am telling it to DO NOT CACHE all the pages? Wouldn't that be the same as just disabling the cache plugin?

  11. YOP
    Member
    Plugin Author

    Posted 7 months ago #

    Hi anefarious1,

    We are sorry but at this point we can only advise to contact the developers at WP Super Cache to assist you on this matter. They should be able to provide dynamic cache. This way, their plugin will not affect YOP Poll.

    Regards,

    YOP Team

  12. hcriad30
    Member
    Posted 5 months ago #

    hey YOP Team:

    I am getting the 'bad request' message as I intended:
    I required voters to be logged in to vote, but I also
    I disabled the wordpress login, otherwise the wordpress sign in pop-up would appear.

    How can I change the 'bad request' message to 'you must log in to vote'?
    Also, how can I increase the font-size of all these output messages?

  13. YOP
    Member
    Plugin Author

    Posted 5 months ago #

    Hi hcriad30,

    Edit inc/yop_poll_model.php and in register_vote function, on line 2802 (for 4.9.1 version) replace

    $this->error = __( 'Bad Request', 'yop-poll' );

    with

    $this->error = "<span style='font-size: 20px;'>" . __( 'Bad Request!', 'yop_poll' ) . "</span>" ;

    You can choose any font size and replace Bad Request with the message you want.

    Regards,

    YOP Team

Reply

You must log in to post.

About this Plugin

About this Topic