WordPress.org

Ready to get started?Download WordPress

Forums

S3 Video Plugin
Buffer Length S3 WordPress Plugin? (7 posts)

  1. zepher
    Member
    Posted 1 year ago #

    Hi, everything installed and linked up good for me. The only issue I'm having is when I play videos it will only play once the whole clip is buffered. I can scrub the slider on the video and see the video, then press play and it will play without it buffering to the end, but only if I scrub the slider. I tried both the flowplayer and the other one and both have the same issue. I'm wanting to put some of my longer form video projects in the S3 bucket, but I'm having the buffering issues and wonder if anyone has has similar issues or something I've missed on config. Thanks!

    http://wordpress.org/extend/plugins/s3-video/

  2. Tevya
    Member
    Posted 1 year ago #

    The problem is your metadata or "headers" are at the end of your video files. So until the entire video file loads, the player doesn't know how long it is or any of that, and therefore won't stream it. You can get a program like http://rndware.info/products/metadata-mover.html to move the headers/meta to the beginning of the video file, and that should fix your problem.

  3. Anthony Mills
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Tevya thats a good tip.

  4. Tevya
    Member
    Posted 1 year ago #

    I dealt with this when using JW Player. Took me a while to figure it out, so I thought I'd share. Unfortunately most NLE's don't put the meta at the beginning, so you have to do this on all video files before uploading. Or if they do, only the very latest versions do this.

  5. Anthony Mills
    Member
    Plugin Author

    Posted 1 year ago #

    Nice one its good to know, I have never come across it personally. But when transcoding videos there is always alot of variables that can cause you problems, so its always good to have one more trick in your bag if a video is causing issues :-)

  6. emptymind
    Member
    Posted 1 year ago #

    My video files will not buffer but only in this player. They stream immediately in other players. They are h.264 movs.
    Any ideas?

    Also I always get the Flowplayer no matter what I select.

    Thanks.

  7. emptymind
    Member
    Posted 1 year ago #

    I just tried the shortcode - which uses jsvideo and buffering was fine, so it is flowplayer issue not my video.

    Problem is that the embed code only use flowplayer right? The area I want to use video will not play the shortcode.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic