WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress install breaks site. (2 posts)

  1. Ian Kath
    Member
    Posted 3 years ago #

    Hi all.

    I'm wanting to install BuddyPress on my sites. I attempted to install it on one site that is using Thesis but it broke the site so I removed the BuddyPress plugin via FTP as I couldn't get to the plugin page. The Thesis forum says they arn't compatible. So I've set up another new site install attached to a .org version of my domain name which I want to keep simple and install BuddyPress there.

    It is only running Twenty Ten, nice and simple and I only have a couple of plugins and no content. I attempted to activate Buddy Press and it broke the site, I removed the plugin as I explained above via FTP, then I tried to do an automatic install of the buddypress plugin and got -

    Fatal error: Call to undefined function is_site_admin() in /hermes/web10/b281/(my domain name)/wp-content/plugins/jet-event-system-for-buddypress/jet-event-system.php on line 39 -

    I seem to be having an issue with this on other sites where I want to install it also. Any ideas?

  2. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    The fatal error with jet-event-system.php is because you attempted to activate the plugin without BuddyPress activated.

    You have to activate the BuddyPress plugin first, then go to Appearance > Themes and choose bp-default theme or a BuddyPress-compatible theme. In addition, make sure that your new WordPress install is working well - image uploads working, creating new subblog working, etc - before installing BuddyPress.

Topic Closed

This topic has been closed to new replies.

About this Topic