WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress
BuddyPress fatal error with default setup (4 posts)

  1. Ryan Hellyer
    Member
    Posted 2 years ago #

    I have a brand new fresh install of WordPress and am getting the following error when attempting to use the built in default theme in BuddyPress ...

    Fatal error: Call to undefined function bp_site_name()

    http://wordpress.org/extend/plugins/buddypress/

  2. Ryan Hellyer
    Member
    Posted 2 years ago #

    Problem solved ... the plugin doesn't work until the "plugin installation" process is performed.

    It seems to me that the plugin should be forcing the installation process on activating the plugin rather than requiring an extra step. I don't have any experience with BuddyPress, so maybe there is some reason that isn't feasible, but just thought I'd put the idea out there.

  3. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 2 years ago #

    Hi Ryan

    How were you able to change to BP-Default before completing the install wizard? Were you installing on a new site that's never been BuddyPress'd, or was it an upgrade from an earlier version?

    When I test on our development/1.6 build, I can't select the theme in Appearance until I start configuring the theme.

  4. Ryan Hellyer
    Member
    Posted 2 years ago #

    I can't recall sorry how I did it sorry. If I get time in the next day or two I'll try it again and let you know how it goes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags