WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Activity Plus
BuddyPress Activity Plus Image Size Issue (11 posts)

  1. relachola
    Member
    Posted 1 year ago #

    After migrating domain from BlueHost to Amazon EC2, images uploaded on the activity posts using the buddypress activity plus plugin is displayed in large size and doesn’t fit in the window. When I double click the image, it displays in the right size. I have tried the following settings in the wp-config.php but didn’t help

    define(‘BPFB_OEMBED_WIDTH’, 2, true);
    define(‘BPFB_THUMBNAIL_IMAGE_SIZE’, ’2×2′);

    I have also tried the suggestions under the topic

    "[Plugin: BuddyPress Activity Plus] How to change image size !??!" on this forum, didn't help.

    Any suggestions/leads is highly appreciated

    http://wordpress.org/extend/plugins/buddypress-activity-plus/

  2. klipari
    Member
    Posted 1 year ago #

    These are from the Instruction Page on the Website from the creator of the plugin.

    you can also set your preferred thumbnail size separately from your default thumbnail size settings, if you wish to do so. You can do that by adding this line to your wp-config.php:

    define('BPFB_THUMBNAIL_IMAGE_SIZE', '200x200');

    Where "200x200" are width and height (in that order), in pixels.

    Finally, be sure to verify your default sizes for embedded media. It's in Settings -> Media -> Embeds -> Maximum embed size

    Limiting photo uploads

    You also have the capability to limit photo uploads by users. Upon first install the limit will be set to 5. However you can change it to anything you like by adding something like this to your wp-config.php: define('BPFB_IMAGE_LIMIT', 5, true);

    So, for an example, to increase the image limit to, say, 10, you would add this to your wp-config.php:

    define('BPFB_IMAGE_LIMIT', 10, true);

    To remove limits entirely and allow unlimited number of images to be shared, just set it to zero, like this:

    define('BPFB_IMAGE_LIMIT', 0, true);

    I think you should check your code and try the examples above. :)

  3. mukesh panchal
    Member
    Posted 1 year ago #

    hii klipari,

    what u suggest this is not a way if u r set media default size then all image have same size every ware in your web site.

    there is any other way.
    thenks klipari
    advance.

  4. relachola
    Member
    Posted 1 year ago #

    Thanks for the detailed response.
    I have tried setting BPFB_THUMBNAIL_IMAGE_SIZE in the wp-config.php as specified in my request and have also verified the default value under the Settings/Media & it did not help either.
    The same code base is working fine on BlueHost server but after I migrated it to Amazon EC2, I have been facing this issue. I am clue less as to how to debug. Please advise

  5. klipari
    Member
    Posted 1 year ago #

    The code above is how the plugin works.

    If you are having an issue now then that means there is some conflict and Amazon EC2 is overriding the settings somehow.

    Does Amazon have it's own variable for thumbnail or media? It seems that it's taking precedence over your BPFB settings.

    If you look closely at the instructions it does not tell you to insert a specific value for your default Media size. It tells you to ensure you have it set to maximum embed size. This is not a specific value and will not change the sizes of anything. It only allows your media to be embedded at it's maximum allowed size.

    I will see if there is any reason for a conflict with Amazon EC2. Bear with me :)

  6. klipari
    Member
    Posted 1 year ago #

    have you checked your:

    php.ini settings for "post_max_size" and "upload_max_filesize"

  7. relachola
    Member
    Posted 1 year ago #

    Help highly appreciated! Look forward to hearing from you again.

  8. klipari
    Member
    Posted 1 year ago #

    Unfortunately the above advice for you php.ini settings is the extent of what i can offer the moment.

    Your server can have different settings that will override the bpap settings

  9. relachola
    Member
    Posted 1 year ago #

    Hi, I have had a response from Amazon which. Please check below

    "
    Often when you upload image files with web based applications they will automatically scale down the image for you to a size which will work better for the web.

    I think what might be happening here is that the wordpress plugin you are using for that part of the site is relying on libraries which you have not yet installed on your instance.

    For example many wordpress plugins rely on the GD libraries being available to perform scaling of images.

    Could you check the requirements for the plugin you are using and then check that against what you have installed on the instance?
    "

    Could you please advice where these libraries are how I can instantiate them?

    Thnaks

  10. klipari
    Member
    Posted 1 year ago #

    Your GD libraries are usually packaged with your php. So you will need to address this with your host to ensure it's enabled on your server :)

  11. LU5DX
    Member
    Posted 1 year ago #

    Hi guys. It's easy to resize and even to use thickbox with Activity Plus.
    A friend of mine told me this topic has been around for quite long and I decided to take a look at the code.
    You can see a working example at http://dxdx.net63.net/activity
    You can see the code for resizing linked images in Activity Plus at
    http://73s.us/LkB8bM
    I'll post on how to use thick box for liked images in Activity plus shortly.

    Have fun.

    Marin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic