WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
"Browser Incompatible" screen whenever WP Super Cache is enabled (5 posts)

  1. slick368
    Member
    Posted 2 years ago #

    I set up a new WordPress site over the weekend. Several times, I checked the site and was greeted by a splash screen with icons from all of the major browsers and a message indicating that my browser was no longer compatible. I have the current versions of IE, FF, Opera, Safari, and Chrome, all of which are the current versions, and they all return the same result on all computers I try it on. Once I turn off the cache, everything returns to normal. I have tried resetting the cache settings to default and deleting the cache files via the Dashboard, but the problems returns, sometimes minutes, sometimes hours, after the cache is re-enabled. I would appreciate some guidance here. It is kind of urgent as this is a client's site and I can't have it crashing on me completely.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry, that's not something that Supercache does. Do you have a plugin that checks the browsers of your visitors? Supercache is probably caching that page when an inappropriate browser visits.

  3. slick368
    Member
    Posted 2 years ago #

    No, I have no such plugin. All I know is that when Supercache is enabled, the problem appears and when SC is disabled, doesn't occur. When it has happened, I have disabled every plugin except SC, and the problem persists. So, I disable SC, the site comes up immediately, with all of the original plugins active. It's puzzling to me. Guess I will leave the cache turned off then until I can determine what is going on. I guess a slower site is better than no site at all. Thanks anyway.

  4. slick368
    Member
    Posted 2 years ago #

    I remembered the test site I had set up and went back to it and, lo and behold, the same screen came up. At this point, the only common elements between the two are the Supercache and the theme. I reverted the theme back to Twenty Eleven and the site came back so, it appears that particular them doesn't like Supercache, or vice-versa. At any rate, I was looking to change that theme out, anyway, so that should solve the problem.

    Thanks for your time and your quick reply!

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    So the theme had the browser warning! Did you try preloading the site? That might have been it because the browser would appear to be a bot to it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic