WordPress.org

Ready to get started?Download WordPress

Forums

Frisco for BuddyPress
[resolved] Broken theme ? (8 posts)

  1. aboudard
    Member
    Posted 8 months ago #

    Hello, I have a question about frisco.
    It works quite well, but I still have a strange message in the Theme section of the admin :

    Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.
    Name Description
    Frisco for BuddyPress The parent theme is missing. Please install the "bp-default" parent theme.

    Could you help me with that ?
    Thank you !

    Alain

    http://wordpress.org/themes/frisco-for-buddypress/

  2. aboudard
    Member
    Posted 8 months ago #

    Ok, I deactivated the buddypress plugin "BP Group documents" 1.3
    And the message is gone.
    I will try to fix that :|

    If you experienced the same problem, I would be happy to know :)

    Alain

  3. aboudard
    Member
    Posted 8 months ago #

    I did contact the author of group documents about that issue and they tell me they contacted you too, if we can manage to resolve, that would be great, because Frisco is a very nice starting theme for BP !

  4. lenasterg
    Member
    Posted 8 months ago #

    @aboudard, hi.
    Can you try the 1.4 version of "BP Group documents" and let me know if it is fixed?

    Bests
    Lena

  5. aboudard
    Member
    Posted 8 months ago #

    Right away !

    Totally awesome, you did fix !
    Could you tell me where the problem was ?
    I am interessed in the code somehow, and I'd like to understand which part of the plugin could crash the dashboard that way.

    Thank you a million for the fast intervention !
    That kind of support surely means donation for the plugin :)

    Alain

  6. lenasterg
    Member
    Posted 8 months ago #

    Thanks for your kind words.

    It was the part where the plugin was init.
    Previous in was on bp_include action hook and produced the error you described.
    If in bp_loaded without priority it also produced the same error.
    If in bp_init it was to late to load the necessery files.

    After a search I found in /buddypress/bp-core/bp-core-actions.php the priority order of bp_actions. The plugin just needed to load after the bp_register_theme_directory action.

    This is now the case, I set the initiallation of BP Group Documents in
    bp_loaded action hook with high priority number (this means it is loaded after the bp_register_theme_directory).

    Hopefully it is not to high and gets broken by other plugins :-)

    Bests Lena

  7. aboudard
    Member
    Posted 8 months ago #

    I will not fail to report any kind of problem like that :)
    Thank you for the detailed explaination, I see the code you refer to.

    Cheers !

  8. serinatran
    Member
    Posted 2 months ago #

    I am getting the same message but I don't have that plugin installed. Is there another reason this error message would show up?

Reply

You must log in to post.

About this Theme

About this Topic