WordPress.org

Ready to get started?Download WordPress

Forums

Edit Author Slug
[resolved] broken since update to 3.5 (8 posts)

  1. karlrt
    Member
    Posted 1 year ago #

    plugin enabled, cache cleared, restarted webserver, still a 404 with the individual slug. while example.com/author/username works.

    You know any other plugin that works like this?

    http://wordpress.org/extend/plugins/edit-author-slug/

  2. karlrt
    Member
    Posted 1 year ago #

    i use this plugin as replacemet now. But i like yours better, hope you find the time to get it fixed...

    wordpress.org/extend/plugins/permalink-editor

  3. Brandon Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I can't reproduce this, and haven't heard any other reports.

    Can you go to Settings > Permalinks in your dashboard, and click "Save Changes"? You do not need to make any changes. Just click the button, and then check to see if things are working.

  4. michelelougheed
    Member
    Posted 1 year ago #

    Thank you. I was having this problem too, but simply pressing Save Changes in Settings > Permalinks solved it.

  5. Brandon Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @michelelougheed

    I've yet to be able to reproduce this, but, as you can see, you're not the only one having this issue. I'm working on what I hope will be a fix, but I want to try and get more information before I release it. Can you give the steps/scenario that lead to the issue?

    Also, do any of the below apply:
    1) you just installed the plugin, then went to the settings page and updated the author base. You try a URL with the new author base, and you get a 404 page.

    2) You had the plugin previously activated, but, for one reason or another, you deactivated. Upon reactivation, the settings page says that you have changed your author base (based on your previous settings), but when you try a URL with the new author base you get a 404 page.

    Thanks in advance for any help!

  6. michelelougheed
    Member
    Posted 1 year ago #

    I think scenario 2 is it. We were having problems with another one of our plugins and all plugins were mass deactivated when the mysql settings on our website were updated to fix the other problem.

    I didn't realise the author links weren't working for about a week.

  7. Brandon Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you! I was able to reproduce and fix scenario 2. I'm hoping something similar to that scenario is where others were having issues as well. Fix will be coming in the next few days. Hopefully, within a few hours.

  8. Brandon Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Version 0.9.5 has been released. This should resolve the issues seen hear, and other similar threads

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags