WordPress.org

Ready to get started?Download WordPress

Forums

Broken RSS feeds and XML errors (8 posts)

  1. Avenir
    Member
    Posted 9 years ago #

    http://www.perfect-illusion.com/feed

    When I load this I get:

    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://www.perfect-illusion.com/feed/
    Line Number 5, Column 1:<?xml version="1.0" encoding="utf-8"?><!-- generator="wordpress/1.5" -->

    I've looked through other posts about broken feeds with similar problems and I've tried going through my wp-rss2.php file and deleting any whitespace before the processing instruction, but I can't seem to fix this problem.

    Also, it seems that the same blank five lines are being inserted at the top of every one of my files. This leads me to believe that the problem isn't in wp-rss2.php but it's somewhere else. But I have no idea where to look.

  2. James
    Happiness Engineer
    Posted 9 years ago #

    De-activate all active plugins and check it again.

  3. Kafkaesqui

    Posted 9 years ago #

  4. Avenir
    Member
    Posted 9 years ago #

    Thank you so much macmanx and Kafkaesqui! I hadn't thought of looking through my plugins but I did find many stray lines in them. Deleting them took some time, but now everything works. Thank you both!

  5. meisenstadt
    Member
    Posted 7 years ago #

    Cross-correlating/posting a few other threads in case it helps; I note that ALL are left at a dead end HELP!

    Broken RSS feeds and XML errors

    Tags do not update Technorati

    RSS feed still not working

    Yahoo RSS failure

    XML Parsing Error: xml processing instruction not

  6. meisenstadt
    Member
    Posted 7 years ago #

    I have a solution that worked for me, primarily involving some single-quote to double-quote conversion in the file wp-rss2.php, for which I have posted the old/new file comparison here on my blog. I am cross-posting this to a total of 5 different threads here on the WordPress support forum, mainly out of a desire to help those whom I know must have also been going crazy with this or similar problems. Many thanks for sticking with it!
    -Marc

  7. Jon Griffith
    Member
    Posted 7 years ago #

    IMHO, this problem is stupid. It shouldn't exist in the first place.

  8. Jon Griffith
    Member
    Posted 7 years ago #

    XML Parsing Error: mismatched tag. Expected: </description>.
    Location: http://www.jongriffith.com/blog/?feed=rss2
    Line Number 133, Column 3:</script>
    --^

    This is what I get...I don't follow how to solve this problem. There's more white-space in EVERY file than I know what do to with.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.