WordPress.org

Ready to get started?Download WordPress

Forums

Broken "previous posts" link (4 posts)

  1. xjt
    Member
    Posted 8 years ago #

    Hi everybody! I'm new with WordPress but it's great, at last I've found a blogging system that works perfectly!

    I just have one problem that is making me go mad. When "previous posts" or "next posts" appear on the bottom of the page (example: http://www.esbos.org/?s=a ) the link is broken, and adds a /esbos/ folder between the domain and the file. It's true that files in the server are not in the root, but inside a folder called "esbos", but the domain http://www.esbos.org points to it directly. I tried to solve it, but I couldn't. Does somebody know why is this happening?

    Thanks you all!

  2. reflexiv
    Member
    Posted 8 years ago #

    I have this same problem. My domain is http://nakba48.org which points to my files are in a directory named nakba48 at grove.ufl.edu.

    All my previous/next post links tack on an extra "~nakba48" so they give a 404 error, for example http://nakba48.org/~nakba48/?cat=7&paged=2 instead of the correct http://nakba48.org/?cat=7&paged=2.

    My wordpress and blog address are both set to http://nakba48.org.

  3. jwallace
    Member
    Posted 7 years ago #

    I have an identical problem at http://www.mameworld.net/agemame/
    - both of my URI settings are set the same, and my permalinks are set to /%year%/%monthnum%/%day%/%postname%/

    If I change them to the default setting, this works, but all I can think of is that somehow the permalink code is breaking down - I have to force .htaccess use to get things to work anyway. Does anyone have any ideas?

  4. jwallace
    Member
    Posted 7 years ago #

    I've so far found that the problem lies in the template-functions, where previous_post_link resides. It looks like the code used to generate the address for that link obtains the blog address first, and then adds the requested link, which in this case breaks down.

    On my site, I've just added some PHP to delete the extra characters, but that's not a real solution, just a hack.

    BTW, this has NOTHING to do with permalinks, by all accounts.

Topic Closed

This topic has been closed to new replies.

About this Topic