WordPress.org

Ready to get started?Download WordPress

Forums

Document Repository
[resolved] Broken on 3.6 (7 posts)

  1. Shutez
    Member
    Posted 8 months ago #

    Hi - the new revisions system in wordpress broke this plugin. It's now impossible to publish any documents. They can only be saved as drafts.

    This message is displayed on any published document.

    "The backup of this post in your browser is different from the version below."

    and publishing is interrupted. Is there a quick fix for this? Thanks!

    Tim

    http://wordpress.org/plugins/document-repository/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 8 months ago #

    Upload the document before filling out the post info (title, etc.), fill out the post info & publish.

  3. Shutez
    Member
    Posted 8 months ago #

    I solved by disabling the "custom taxonomies" plugin.

    However, there's a bigger problem with this version.

    I'm just using a loop and calling the_content(); to get all documents of a certain type. Before, I would get the document title, the content from the editor screen and the link.

    Now I just get the editor content and a "download" link.

    Did something else change?

  4. Shutez
    Member
    Posted 8 months ago #

    How do I change

    <a href="document_link" title="document_title">Download</a>

    to

    <a href="document_link">document_title</a>?

  5. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 8 months ago #

    if the_content() was generating the title before then you had to have had a plugin or theme filtering the content. The the_content() template tag has the post content. That template tag has not changed since I first started using WP (c. 2005).

    Use the_title() to display the post title.

  6. Shutez
    Member
    Posted 8 months ago #

    Never mind I got it.

    <a href="<?php the_permalink();?>"><?php the_title(); ?></a></li>

    Sorry - it's been a while. I must have altered the source code before and it got overwritten. All is working as it should. I'll change my vote. Feel free to close this.

  7. Shutez
    Member
    Posted 8 months ago #

    thanks for everything - cross posted there. I appreciate the help. Great plugin - hope it continues to get use and support.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.