WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] broken links to static pages in MS subfolder (5 posts)

  1. habo
    Member
    Posted 2 years ago #

    Greetings,

    I’m not particularly experienced in WordPress but have built a couple of websites.

    I have made a fresh installation and activated multi-site with subfolders (both manually and with the plugin multi-site enabler).

    The main site (borgstromsforlag.se) works fine. But I have problem with links to static pages in the menu in the child site (borgstromsforlag.se/energinsmysterier). It is impossible to navigate to the pages. The menu doesn’t find the pages (om boken, kapitel, lankar, foton, etc). I have of course created these pages but the menu leads to a “noting found”. I assume there must be something wrong with the htaccess file or the permalinks structure?

    I have scanned the forum, but I can’t find anyone with similar problems. Do you have any ideas of what can be wrong?

    Here is my htaccess:

    #Made Multi-Site with Multi-Site Enabler 1.5#
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    And the permalink setting for the child site looks like this:
    /%year%/%monthnum%/%day%/%postname%/

    This is the upload folder:
    C:\xampp\htdocs\borgstromsforlag\wp-content\blogs.dir\2\files\20118

    Cheers,
    Hakan

  2. We've seen a number of people have issues with the plugin. There are very few steps in enabling multisite, so I suggest you remove the plugin and follow the directions for creating a network.

    http://codex.wordpress.org/Create_A_Network

  3. habo
    Member
    Posted 2 years ago #

    Andrea,

    Thanks for answering,

    As I wrote - I first tested to activate MS manually, then with the plugin. The result was the same: No links to static pages.

    But I know found out that if I changed permalinks from pretty (default with plugin) to ugly it all works! All I did was change from:

    http://mysite.se/subfolder/2011/08/07/sample-post/
    to
    http://mysite.se/subfolder/?p=123

    Cheers,
    Hakan

  4. That means you have other issues, just FYI. You shouldn't need to use ugly permalinks (and what 'default with plugin' plugin are you using?)

  5. multisite itself uses pretty permalinks by default. that part had nothing to do with the plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic