WordPress.org

Ready to get started?Download WordPress

Forums

Broken images following upgrade from WPMU to 3.0 (3 posts)

  1. hermida
    Member
    Posted 4 years ago #

    I updated http://thethunderbird.ca/ from WordPress MU to 3.0. I have also updated the htaccess file. But some of the images are now missing, though not all of them.

    Any suggestions as to why this is happening? Thanks

  2. gazouteast
    Member
    Posted 4 years ago #

    Current suspects =

    htaccess content not being updated during the upgrade (lot of people suffering from this one)

    htaccess not being updated when permalinks are saved after upgrade (a lot of people also suffering this one)

    renaming of the WPMU 2.9.2 /uploads/ path to /files/ by WP 3.0

    Use of the /files/ path in an htaccess mod.rewrite rule (file and files are reserved command words for mod.rewrite - WP goofed badly on that one)

    Incorrect entries in the server's httpd.conf file related to follow-all symlinks, and in the vhosts section for subdomain installs - though if it worked in 2.9.2 this SHOULD NOT surface as a problem under 3.0 BUT IT HAS and the core devs are denying it is happening on open trac.wordpress.com tickets

    ... basically, WP completely mucked up with trying to force hosting services to modify their offerings to fit "the world according to wordpress" instead of building wordpress 3.0 to fit the existing hosting world.

  3. gazouteast
    Member
    Posted 4 years ago #

    oh yeah - and forgot the forced case conversion from wordpress or WordPress to WordPress via the capital-P-dangit() function added in 3.0 - I've seen several proof-positive cases reported in the forums where the server-side folder for the install had it's name changed by that, and of course Apache and Linux are case sensitive, therefore it made the entire site inaccessible.

Topic Closed

This topic has been closed to new replies.

About this Topic