WordPress.org

Ready to get started?Download WordPress

Forums

MesoColumn
[resolved] Broken hAtom 0.1 structure (10 posts)

  1. Denver Prophit Jr.
    Member
    Posted 6 months ago #

    I previewed your theme here on wordpress.org and viewed frame source. The message body did put the entry class. The title, author, description entries for hAtom are not present. hAtom markup will not be obtained from google or bing.

  2. Richie KS
    Member
    Theme Author

    Posted 6 months ago #

    ?????????????????did the same result on my own demo site????

  3. Denver Prophit Jr.
    Member
    Posted 6 months ago #

    wordpress.org is only using what you have submitted to them, right? If I view the demo from wordpress themes, it's your latest release. Not being nitpicky. But, it's something to examine.

    What's the trac link to your theme?

  4. Richie KS
    Member
    Theme Author

    Posted 6 months ago #

    yeah i know but wp.org might block atom/xml feed or because of the iframe they use. go to theme author site and live preview.

  5. Denver Prophit Jr.
    Member
    Posted 6 months ago #

  6. Richie KS
    Member
    Theme Author

    Posted 6 months ago #

    i see, you were talking about schema markup or rich snippet.
    nope, the theme did not support this. it did in earlier version but were removed by theme guideline. and were suggested using wp plugin instead

  7. Denver Prophit Jr.
    Member
    Posted 6 months ago #

    You still have some hatom markup. hatom is included in most WP public themes. Mostly broken on each. But, still there heh. Plugins bloat memory. It's best to markup at least hatom in the theme.

  8. Richie KS
    Member
    Theme Author

    Posted 6 months ago #

    yeap, i'm testing the demo with edits now. will update this thread again

  9. Denver Prophit Jr.
    Member
    Posted 6 months ago #

    If you go forward with fixing hatom, you can insert the tag: microformat in your stylesheet. WP theme search does have that tag to search themes.

  10. Richie KS
    Member
    Theme Author

    Posted 5 months ago #

    try update to latest mesocolumn v1.6.3
    the microformat should work now.

Reply

You must log in to post.

About this Theme

About this Topic