WordPress.org

Ready to get started?Download WordPress

Forums

Broke my own site when moving directory (19 posts)

  1. 993C4S
    Member
    Posted 6 years ago #

    Hi,

    I was following the instructions from here
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    when I got to step 5 I was immediately presented with the following error..

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    I now can't access the blog or the admin panel no matter what URL I try.

    Worpress address is: campliving.com/wordpress
    Blog address is: campliving.com

    I have already changed and moved the index.php file.

    Anythoughts would be appreciated.

  2. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    You should be able to login to your site thru what ever your host assigns you for site admin like vdeck or whatever.

    Then you can see all the files.

  3. 993C4S
    Member
    Posted 6 years ago #

    I can see the files (through ftp or through my host GoDaddy), but I don't understand what it broken or what to change/fix.

  4. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Find the file index.php. It should be in the root of the directory where you were moving your blog or it may be in the root of the directory where your blog was.

    You should be able to go to that address with your browser.

  5. 993C4S
    Member
    Posted 6 years ago #

    Okay, my WordPress aplication was originally installed at

    campliving.com/wordpress and running fine for months. I decided I wanted to leave the application where it was but change it so that the campliving.com was the root directory for the blog. So...

    All I did was follow the instructions in the link that I started this post with.

    when I clicked on update I immediately received the Server Error I referenced.

    The index file at the root level reads:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>

    Should I delete the index file in the campliving/wordpress directory that reads:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    I can't get to either one.

  6. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    If you can see the files and yet you (me also) cannot get to them with the address in the browser maybe it is indeed a 500 error and you should contact your host.

    Can you still ftp? If so, just follow the rest of the instructions. If not, (as I suspect) even more of a reason to call the host.

  7. 993C4S
    Member
    Posted 6 years ago #

    Thanks for all the help. I have put in a support ticket with GoDaddy. I can still ftp.

    Do you have any idea what file gets updated when you change the address of the Blog URL in the admin folder.

    Maybe I can manually edit that?

  8. moshu
    Member
    Posted 6 years ago #

    After re-reading this thread I've added an important sentence to that #5 in the Codex guide:

    (Do not worry about the error message and do not try to see your blog at this point!)

    And no files are 'updated': all your settings are stored in the datasbase.

  9. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Thanks moshu!

    "I can still ftp." Great, "just follow the rest of the instructions."

  10. 993C4S
    Member
    Posted 6 years ago #

    Moshu,

    Thanks. However,

    As you can see, I did finish the instructions

    The index file reads

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wordpress/wp-blog-header.php');
    ?>

    However, I can't access any URL at all. Any thoughts?

  11. moshu
    Member
    Posted 6 years ago #

    Did you copy the htaccess file, too, as indicated in the guide?
    (of course, if you have one)

  12. 993C4S
    Member
    Posted 6 years ago #

    Yes, but I've since deleted. I can put it back in, but it is not updating. what should it look like from a code standpoint?

    As a side note. I do not have an htaccess file in the root directory of any of my other blogs.

  13. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Looks like you got it!

  14. 993C4S
    Member
    Posted 6 years ago #

    Thank you both for your help. I wish I could tell you I know why, but the site is back up.

    Kmessinger, i'm thinking you might have been right from the beginning that it really was a hosting issue. I put in a ticket (haven't heard back yet), but outside of that I haven't done anything else.

    So, for whatever reason, I can now get to my blog at http://www.campliving.com

    Once again I appreciate the input from both of you.

    John

  15. jpxwordpress
    Member
    Posted 6 years ago #

    Hi I think something very similar or even exactly the same just happened to me as it did for 993C4S:

    After previously having my blog located at MYSITE.COM/BLOG, and wanting to keep all of the original blog files and postings in the Blog folder, and just access them from my ROOT.com folder), my blog is now completely inaccessible.

    I first tried following the 'Giving WordPress its own directory' page instructions and changing the specs on the Options page to:
    WordPress address (URL): MYSITE.COM/BLOG and
    Blog address (URL): MYSITE.COM) and also editing the index.php file (in the root folder) to require('./wp-blog-header.php'); - [taking out the require('./BLOG/wp-blog-header.php'); Lastly, I copied and pasted the code that the Admin page told me to insert into the .htaccess file, and ftped them to the served. At first the blog WAS loading into the ROOT url address, but I still saw a lot of posts as '..../blog/post-name....' yet they all seem to have their URL name automatically change to '.......ROOT/post-name...', so after that, I went back into the Wp-Admin page, selected my site's ROOT URL for both

    WordPress address (URL): MYSITE.COM and
    Blog address (URL): MYSITE.COM), and then that's when the "barbecuing of my blog" began to occur.

    Please help - would be SO much appreciated, as neither I nor anyone else can access my site's blog at the moment or publish for it - :(

    Thank you so much in advance.....

  16. jpxwordpress
    Member
    Posted 6 years ago #

    UPDATE: I was since able to retrieve my Admin-Dash (which fortunately game me access to all of my blog's posts), but now, everytime I try to load a post (with the '*BLOG/' removed - so before it was mysite.com/blog/a-post, no the URL on the home page lists as mysite.com/a-post - i.e. everything with the 'BLOG' is auto-removed), but I just get a 404 - File not Found everytime I click on the link.

    Now I am wondering that EVEN if I have to start all over again, what will happen if I want to use my site's root for posts - very perplexing and disturbing. I do of course have confidence that the posts are there, since they are in the database, but I would really like to resolve this issue. Thanks everyone.

  17. jpxwordpress
    Member
    Posted 6 years ago #

    Oh and I AM able to edit posts here:
    MYSITE.com/BLOG/wp-admin/edit.php

    but when I try to view a post or the actual MYSITE.COM/BLOG

    I get another 'File not Found' - arg.

    ANOTHER UPDATE: Now all appears OK (at least in terms of being able to get back to the 'BLOG/.....' structure, which I still will want to get rid of eventually, and just move posts and categories to MYSITE.COM/etc), yet (at least in Firefox) when I try to Log Out, it won't let me and re-directs me everytim to the Admin Dash. Oh and by the way I am using WP 2.5.1 - some craziness indeed..... I'm even wondering if it's a server - hosting provider propagation thing - where it takes some time to update - I also tried to put:

    WordPress address (URL): MYSITE.COM/ and
    Blog address (URL): MYSITE.COM/BLOG)

    to try to take out the "blog" portion of the URL etc.

  18. moshu
    Member
    Posted 6 years ago #

    Why don't you just follow the instructions at the tutorial linked in the OP (original post), instead of trying to re-invent the wheel?

    Read it carefully, it has the answers for all your questions. If it says copy - it means copy and not "move". It also tells you excactly which URL to change, so no need for "experimenting".

  19. jpxwordpress
    Member
    Posted 6 years ago #

    moshu, thank you! I don't know what happened before - if the problem was that I incorrectly entered in the code to put into the 'index.php' file, or if it was because I altered my FTP client settings (this time) to allow for 'Group Write' for the '.htaccess' file in my site's root directory (per this post:
    http://codex.wordpress.org/Changing_File_Permissions), but apparently it works now - I AM JUST SO RELIEVED that I will not have to re-post around 300 posts to the new edition of my blog site. Maybe it's the little things I don't know.....

    Just one other question though, if I leave publishing settings as 'Group Write' for the '.htaccess' file (allowing WordPress to auto-update the contents of this file), would that pose any security threats to my site - i.e. allowing any vulnerability to coding attacks of any kind?

    Thank you so much again, I knew that WordPress still really rocks the house.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.