WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
Broke my css (11 posts)

4 stars
  1. Mladen Gradev
    Member
    Posted 1 year ago #

    This plug-in broke my style sheet. I suppose this don't happen to everybody, but for me it was a disaster.

  2. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    That clearly should not happen.

    That's a pity Mladen. Some questions so I could try to improve things:

    • Can you provide me with the URL of your site, so I can have a look at the CSS?
    • Do you have a non-production site with the same or similar theme/ look&feel where I could check what is happening?
    • What WordPress theme are you using?
    • Did you try with Autoptimize 1.5.1 which I pushed out yesterday, or with 1.5.0 (which had a known issue with the order in which CSS-files were loaded)?
  3. Mladen Gradev
    Member
    Posted 1 year ago #

    Hi and thank you for your quick respond.
    Actually the situation is not exactly disastrous, but bad enough for me. The problem is that all css images are not showing in Firefox only. Those are strikes for lists, icons for tags and categories, sprites for prettyphoto etc. Only Firefox is affected, the paths to images are correct. The website is not in english, but if click on any post in gallery you can see the problems.

    - http://www.tsarevo.info/galeriya/
    - No, I don`t have any other site
    - The theme is called WP-Clear
    - I believe i have tried the latest version 1.5.1

  4. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Some background-images indeed do not seem to load in Firefox (see screenshot here), but you're not using Autoptimize now, are you?

    When looking in Firebug, I see several files from http://www.stat.tsarevo.info that don't get loaded with a HTTP 403 error ("forbidden") instead of a valid HTTP 200 or 304 response code cfr. this screenshot. Same for a.o. /css/images/white-inside-skin-sprite.png and /css/images/black-and-white-skin-sprite.png.

    Given:

    • You aren't using Autoptimize now
    • some images aren't displayed
    • the 403 errors

    I think that you're experiencing a very weird problem with (the configuration of) http://www.stat.tserevo.info which is not related to Autoptimize?

  5. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Any news about why some images aren't being served from http://www.stat.tserevo.info even when there's no Autoptimize in the picture Mladen?

  6. Mladen Gradev
    Member
    Posted 1 year ago #

    Hi futtta,
    No, I dont know why those images are not loading. I get really confused with this cookieless sub domain thing and i am trying to get things back to how they was. There was some cache left after I delete the plugin, and thought that everything will be ok when i delete it, but no luck. However, I am pretty sure that all of this started after installing Autoptimize. Dont know if the plugin cause it, but it started then.

  7. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    OK, hope you can revert to the previous situation.

    To make sure Autoptimize is entirely deleted, you should;

    • remove /wp-content/plugins/autoptimize/
    • remove /wp-content/cache/autoptimize/

    If you'd like some assistance, you can contact me at futtta-at-gmail-dot-com. And if it's any consolation (it is for me); I'm 100% sure this isn't caused by Autoptimize :-)

  8. Mladen Gradev
    Member
    Posted 1 year ago #

    OK, I must admit, I was wrong about this plugin :) Actually it is doing pretty good job with optimization. But still there are two problems that I can not resolve:
    1. There is a blank space in footer with text Error 003. I have weather widget in my sidebar, which is not a plugin, it is just a javascript code put in text widget - the code. After some investigation with Firebug i understood that this weather widget somehow is going down in the footer.
    2. There are two ads in the sidebar, one of them is from Google and the other is from local ad management company. The second ad (the local) is not showing, don`t know why. Here is the code.

    Can you please take a look of this problems? It will be great if you help me to remove those error.

    Thanks :)

    p.s. By the way, all JavaScript Options buttons are checked + Optimize HTML Code. Nothing else.

  9. Mladen Gradev
    Member
    Posted 1 year ago #

    p.p.s. Is there any way to exclude some scripts from optimization?

  10. Frank Goossens
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there Mladen, glad you got the missing image problem solved!

    Regarding the two remaining issues; just check the box next to

    Look for scripts only in <head>?

    This should solve both problems (tested successfully with the weather-widget).

    Excluding script in this version can be done by editing the array "dontmove" in /wp-content/plugins/autoptimize/classes/autoptimizeScripts.php. In a future version I'll probably include a text-field in the admin-screen.

  11. slodds
    Member
    Posted 10 months ago #

    For anyone looking to get their adsense or infolinks back this solution worked perfect for me. It also had no effect on scores from page speed insights or Yslow by enabling this option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.